Package Release Info

scalapack-mvapich2-2.1.0-bp153.2.13

Update Info: Base Release
Available in Package Hub : 15 SP3

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

blacs-devel-headers
libblacs2-mvapich2
libblacs2-mvapich2-devel
libblacs2-mvapich2-devel-static
libscalapack2-mvapich2
libscalapack2-mvapich2-64bit
libscalapack2-mvapich2-devel
libscalapack2-mvapich2-devel-64bit
libscalapack2-mvapich2-devel-static
scalapack-mvapich2-test

Change Logs

* Wed Feb 03 2021 Egbert Eich <eich@suse.com>
- Change 'Requires:' to other HPC packages to %requires_eq to depend
  on the exact version. This should take care of HPC packages ignoring
  proper ABI versioning.
* Tue Jan 05 2021 Egbert Eich <eich@suse.com>
- Fix build for non-HPC packages: do not build BLACS headers for
  multiple flavors (boo#1178116).
* Thu Jul 23 2020 Egbert Eich <eich@suse.com>
- Add build support for gcc10 to HPC build (bsc#1174439).
* Thu Jul 16 2020 Egbert Eich <eich@suse.com>
- Add openmpi4 spport (provided by Alin M Elena)
- Replace -fallow-argument-mismatch by -std=legacy
* Wed Jun 17 2020 Egbert Eich <eich@suse.com>
- Add compiler flag -fallow-argument-mismatch to allow build with
  gcc10.
Version: 2.0.2-bp151.1.1
* Wed Feb 13 2019 Egbert Eich <eich@suse.com>
- Consolidate use of openmpi1, openmpi2, openmpi3 for non-HPC builds.
- Disable openmpi1/3 and non-HPC builds on SLE.
* Wed Dec 12 2018 Todd R <toddrme2178@gmail.com>
- Also build for regular openmpi2 and openmpi3.
* Fri May 11 2018 eich@suse.com
- Fix HPC build that broke with last change: the BLACS headers
  need to be provided always (boo#1092881).
* Thu Apr 26 2018 jberry@suse.com
- Only produce blacs-devel-headers package once (in openmpi)
  (boo#1092881).
* Sat Feb 10 2018 eich@suse.com
- Fix setting of
  * LIBRARY_PATH
  * PKG_CONFIG_PATH (boo#1080426).
  * Fix headers (boo#1080434).
* Fri Feb 09 2018 eich@suse.com
- Since the OpenBLAS build was fixed, reenable scalapack
  on s390 (bsc#1079513).
- Add support for openmpi2 for HPC (FATE#325089).
* Fri Feb 09 2018 cgoll@suse.com
- Fix summary in module files (bnc#1080259)
* Tue Feb 06 2018 eich@suse.com
- The HPC build of scalapack requires openBLAS. OpenBLAS is not
  supported for s390: skip building on s390 for HPC (bsc#1079513).
* Wed Jan 17 2018 eich@suse.com
- Don't set the module package to noarch. It contains arch specific
  directory paths (boo#1076443).
* Fri Jan 12 2018 eich@suse.com
- Disable the openmpi3 flavor in some products.
* Fri Jan 05 2018 eich@suse.com
- Switch from gcc6 to gcc7 as additional compiler flavor for HPC on SLES.
- Add support for openmpi3 and mpich to HPC build.
* Tue Nov 14 2017 cgoll@suse.com
- changed location of test files in order to make tests functional
* Fri Nov 10 2017 eich@suse.com
- Add libopenblas*devel as Requires to the devel package for
  HPC.
* Thu Oct 19 2017 eich@suse.com
- Fix blacs master packages.
* Mon Oct 16 2017 eich@suse.com
- Make sure the Factory validator gets %pname as package name.
* Fri Sep 08 2017 eich@suse.com
- Convert to multibuild
- Add HPC build using environment modules
  (FATE#321715).
- Generate baselib.conf dynamically and only for the non-HPC
  builds: this avoids issues with the source validator.
* Fri Jul 24 2015 dmitry_r@opensuse.org
- Fix BLACS devel package dependence list
* Tue Jul 07 2015 dmitry_r@opensuse.org
- Build BLACS shared libraries
  * scalapack-2.0.2-shared-blacs.patch
* Wed Nov 05 2014 dmitry_r@opensuse.org
- Add baselibs.conf to source list
* Wed Jun 04 2014 dev@stellardeath.org
- Fix shared library, the *.oo files were missing
Version: 2.1.0-bp152.1.1
* Sat Mar 28 2020 Egbert Eich <eich@suse.com>
- Remove blacs HPC master packages: the libblacs has been removed
  (boo#1167949).
* Thu Dec 05 2019 Egbert Eich <eich@suse.com>
- Add a Provides: for the removed BLACS library package for HPC.
  libscalapack contains the BLACS ABI.
* Sat Nov 30 2019 Egbert Eich <eich@suse.com>
- Updated to v2.1.0 (jsc#SLE-11037)
  * New robust ScaLAPACK routine for computing the QR factorization with
    column pivoting by Zvonimir Bujanovic and Zlatko Drmac [Download Lawn 296]
  * MPI-3+ updates required by Open MPI 4
  * Improve accuracy of Frobenius norm by making intermediate column sums
  * miscellaneous minor bug fixes
  * Improve cmake shared library support
- Disable openmpi1 builds for SLE/Leap > 15.1.
- Enable openmpi3 builds for Leap and SLE > 15.1 (jsc#SLE-7773).
- Add support for gcc8 and gcc9 builds for HPC (jsc#SLE-7766,
  jsc#SLE-8604).
- For HPC no longer provide BLACS as a separate library.
- Remove:
  * scalapack-2.0.2-shared-blacs.patch
  * scalapack-2.0.2-shared-lib.patch
    Handled in spec file.
* Mon Nov 25 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
- Reflect renaming of openmpi packages to openmpi1 in Tumbleweed,
  fixes unresolvable packages.
* Tue Sep 10 2019 Ana Guerrero Lopez <aguerrero@suse.com>
- Use -ffat-lto-objects to provide a proper static library.
* Tue Jul 16 2019 Michel Normand <normand@linux.vnet.ibm.com>
- Add BuildRequires blacs-devel-headers for non-hpc when required.
- Add BuildRequires libopenblas-gnu-hpc >=  0.3.6 for hpc to  avoid
  to build when openblas library not available.
* Fri Feb 22 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
- spec file cleanup:
  * Use %license, remove %defattr
  * Shorten descriptions and fix some typos
  * Remove redundant (and wrong) pointer to test data install dir