Package Release Info

mumps-mvapich2-5.3.5-bp154.1.32

Update Info: Base Release
Available in Package Hub : 15 SP4

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

libmumps5-mvapich2
libmumps5-mvapich2-compat
libmumps5-mvapich2-debuginfo
mumps-mvapich2-debuginfo
mumps-mvapich2-debugsource
mumps-mvapich2-devel
mumps-mvapich2-devel-static
mumps-mvapich2-devel-static-compat
mumps-mvapich2-examples
mumps-mvapich2-examples-debuginfo

Change Logs

Version: 5.1.2-bp151.1.1
* Wed Apr 03 2019 Christian Goll <cgoll@suse.com>
- added version flavor to scotch-openmpi[23] (bsc#1131426)
* Wed Feb 27 2019 Egbert Eich <eich@suse.com>
- Use -Wl,--whole-archive .. -Wl,--no-whole-archive instead of unpacking
  static library to build a shared library.
- Add dependency to gcc-gfortran to non-HPC build of devel package.
* Wed Feb 27 2019 Egbert Eich <eich@suse.com>
- Makefiles-Serialize-libseq-libplat-mommond_mod-for-parallel-builds.patch
  * Add missing dependency to serialize sub-builds.
* Mon Feb 25 2019 Torben Mikael Hansen <torhans-build@sciomnis.com>
- Changed requirements for openmpi (non-hpc) version
  %%mpi-ver -> %%mpi-ext: openmpi1 flavors omit the version number.
* Fri Feb 22 2019 Egbert Eich <eich@suse.com>
- Add conflicts between scotch and non-scotch flavors of example
  packages.
* Thu Feb 14 2019 Egbert Eich <eich@suse.com>
- Ship header files with devel package for each HPC build (bsc#1125551).
* Thu Feb 14 2019 Jan Engelhardt <jengelh@inai.de>
- Update RPM groups.
* Thu Feb 14 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
- Add explicit Requires: for matching libblacs2-* to non-HPC library package
* Tue Feb 12 2019 Egbert Eich <eich@suse.com>
- Fix product groups.
- Fix dependencies.
- Consolidate use of openmpi1, openmpi2, openmpi3 for non-HPC builds.
* Mon Feb 11 2019 Egbert Eich <eich@suse.com>
- Fix License.
* Sat Feb 09 2019 eich@suse.com
- Simpify naming scheme.
- Fix more dependencies.
- Rename package: test -> examples.
- Create HPC master package for doc and examples.
- Fix shared library builds.
- Build example binaries against shared libs for all builds.
- Add Makefiles-Serialize-libseq-libplat-mommond_mod-for-parallel-builds.patch:
  make sure builds are serialized for 'make -j <n>'
- Version mumps, requires and buildrequires, remove unneeded buildrequires.
- Only include requires for the respecive flavor (non-scotch, scotch).
* Fri Feb 08 2019 eich@suse.com
- Split off static packages & their link package (where applicable).
- Fix dependencies for devel packages.
* Thu Feb 07 2019 eich@suse.com
- Update to version 5.1.2
  See Changelog file or http://mumps.enseeiht.fr/index.php?page=dwnld
- Convert to full multibuild support: builds with scotch support
  are separate, now.
- Add HPC support (FATE#324151).
- Move links from the sequential libraries to the MPI library directory
  to a separate package, make this package an optional Recommends:
  of the non-HPC library packages.
- Move documentation to separate package.
- Disable non-HPC builds and some MPI flavors for SLE.
* Sun Jan 20 2019 eich@suse.com
- Fix dependencies: All scotch devel packages come without 'lib'
  prefix, now.
* Tue Jan 08 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
- Refactor spec for _multibuild, currently non-HPC flavors only.
- Setup MPI environment when building MPI flavors, fixes build on
  Tumbleweed, Leap 15.x, SLE 15.
* Sat Nov 21 2015 scorot@free.fr
- fix build against recent scalapack which includes blacs library
* Wed May 22 2013 scorot@free.fr
- fix build for Factory and recent openmpi
* Wed Sep 19 2012 scorot@free.fr
- install missing headers for the sequential version
* Wed Sep 19 2012 scorot@free.fr
- fix broken requirements of mpi devel packages
* Tue Aug 21 2012 scorot@free.fr
- split devel packages with devel and scotch-devel
- devel packages don't require scotch-devel anymore
Version: 5.2.1-bp152.2.1
* Tue Jun 02 2020 Egbert Eich <eich@suse.com>
- Add macros to handle building of openmpi1 flavors for serial
  builds as well (bsc#1172345).
* Tue Dec 03 2019 Egbert Eich <eich@suse.com>
- Set %mpi_ver for scotch-openmpi
- Remove requires for libblacs from HPC builds which is not
  required there.
- Add openmpi3 non-HPC build flavor.
- Remove libblacs as explicit dependency for HPC build. BLACS
  is part of scalapack.
* Fri Nov 29 2019 Egbert Eich <eich@suse.com>
- Add support for gcc7 builds for HPC.
- Add support for gcc8 and gcc9 builds for HPC (jsc#SLE-7766 &
  jsc#SLE-8604).
* Thu Nov 28 2019 Egbert Eich <eich@suse.com>
- Disable openmpi1 builds for SLE/Leap > 15.1.
- Enable openmpi3 builds for Leap and SLE > 15.1 (jsc#SLE-7773).
* Mon Nov 25 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
- Reflect renaming of openmpi packages to openmpi1 in Tumbleweed,
  fixes unresolvable packages.
* Mon Sep 09 2019 Ana Guerrero Lopez <aguerrero@suse.com>
- Update Source0, file is gz and not bzip2
- Use -ffat-lto-objects to provide proper static library.
* Wed Aug 28 2019 Ana Guerrero Lopez <aguerrero@suse.com>
- Update to version 5.2.1 (jsc#SLE-9939)
  * See ChangeLog file or at http://mumps.enseeiht.fr/index.php?page=dwnld
- Refresh patch:
  * Makefiles-Serialize-libseq-libplat-mommond_mod-for-parallel-builds.patch
- Install the new binaries provided with the examples.
* Wed Jul 17 2019 Michel Normand <normand@linux.vnet.ibm.com>
- Add BuildRequires libopenblas-gnu-hpc >=  0.3.6 for hpc to  avoid
  to build when openblas library not available (ppc64)
Version: 5.3.5-bp153.2.1
* Fri Mar 26 2021 Egbert Eich <eich@suse.com>
- Fix name of compat library package (bsc#1184057).
- Remove a non-existent Recommends: in non-HPC package.
* Thu Feb 25 2021 Christian Goll <cgoll@suse.com>
- updated to version 5.3.5, changes are
  * Fixed 2x2 pivots bug from 5.3.4 release in MPI LDLT factorization
  * Fixed ICNTL(8)=-2 option during analysis (code and documentation)
  * Fixed a rare bug (segfault) related to dynamic storage management on numerically difficult matrices
  * Fixed a rare deadlock in BLR for symmetric matrices
  * Fixed an uninitialized variable (which could lead to incorrect -19 error)
  * Minor fix in userguide (CNTL(1) vs. ICNTL(1) in ICNTL(36) description)
  * Fixed a possible runtime issue during solve, related to "TO_PROCESS" array
  * Assume ilp64 MPI interface only applies to Fortran in c_example.c
  * Note on gfortran-10 compilation added
  * Avoid intent on pointers (F2003-only)
  * More robust multithreading for matrix reformatting (arrowheads)
  * Fixed ICNTL(31) interpretation in case of repeated analysis
  * Fixed multiple mpif.h inclusion (distributed rhs, ifort+openmpi)
  * Fixed computation of effectively used memory statistics
  * Improved multithreaded performance of BLR backward solve
  * Fixed return code in build_mumps_int_def.c + openmp compilation (pgi)
  * Forbid a loop vectorization in [sdcz]sol_c.F (segfault with ifort)
  * New feature: distributed right-hand sides
  * Improved time for arrowheads construction (single MPI case, mainly)
  * C interface: ability to know if MUMPS_INT is 64-bit from include file
  * Improved BLR performance when CNTL(1)=0.0 and ICNTL(36)=1
  * Fixed INFO(34),INFO(35),INFO(37),INFO(38) on processes with rank > 0
  * More portable MPI_IS_IN_PLACE feature in libseq
  * Fixed determinant computation when Cholesky ScaLapack is used
  * Information on advancement (flops done) on each MPI process
  * Allow rhs_sparse and irhs_sparse to be unassociated if nz_rhs=0
  * Fixed INFO(30) and INFO(31) computation on MPI processes with rank > 0
  * OMP collapsed loops: avoid FIRSTPRIVATE on internal loop bound (for pgi)
  * Fix for compilers not freeing local allocatable arrays (64-bit metis)
  * Fixed RINFO(5-6) and RINFOG(15-16) metrics (entries=>bytes)
  * C interface: A_ELT/SCHUR/RHS/REDRHS/RHS_loc/SOL_loc may exceed 2^31 entries
  * Local Schur (ICNTL(19)=2 or 3) may now exceed 2^31 entries
  * Fixed internal dynamic storage of blocks with more than 2^31 entries
  * Fixed a bug in the parallel analysis that limited scalability
- removed Makefiles-Serialize-libseq-libplat-mommond_mod-for-parallel-builds.patch
  * functionaltiy is included upstream
* Fri Feb 05 2021 Egbert Eich <eich@suse.com>
- Disable openmpi4 builds for SLE/Leap < 15.3.
* Thu Jan 28 2021 Egbert Eich <eich@suse.com>
- Change 'Requires:' to other HPC packages to %requires_eq to depend
  on the exact version. This should take care of HPC packages ignoring
  proper ABI versioning.
* Thu Jul 23 2020 Egbert Eich <eich@suse.com>
- Add build support for gcc10 to HPC build (bsc#1174439).
  * Remove explicit build dependency for libgomp1.
  * Add missing compiler versions to openblas and scalapack
    build dependencies.
- Add build support for openmpi4.
* Tue Jun 30 2020 Egbert Eich <eich@suse.com>
- With gcc10, some fortran code started failing to build -
  add compiler option -std=legacy to fix (bsc#1173549).
* Thu Feb 14 2019 Egbert Eich <eich@suse.com>
- Ship header files with devel package for each HPC build (bsc#1125551).