Package Release Info

vim-plugins-7.3.0-bp154.2.18

Update Info: Base Release
Available in Package Hub : 15 SP4 (BETA)

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

vim-plugin-a
vim-plugin-ack
vim-plugin-align
vim-plugin-bufexplorer
vim-plugin-calendar
vim-plugin-colorschemes
vim-plugin-colorsel
vim-plugin-diffchanges
vim-plugin-editorconfig
vim-plugin-file-line
vim-plugin-fugitive
vim-plugin-gitdiff
vim-plugin-gnupg
vim-plugin-latex
vim-plugin-locateopen
vim-plugin-markdown
vim-plugin-matrix
vim-plugin-minibufexpl
vim-plugin-multiplesearch
vim-plugin-neomutt
vim-plugin-NERDcommenter
vim-plugin-NERDtree
vim-plugin-project
vim-plugin-quilt
vim-plugin-rails
vim-plugin-salt
vim-plugin-searchcomplete
vim-plugin-showmarks
vim-plugin-snipmate
vim-plugin-supertab
vim-plugin-taglist
vim-plugin-tlib
vim-plugin-tregisters
vim-plugin-tselectbuffer
vim-plugin-tselectfiles
vim-plugin-utl
vim-plugin-vimwiki
vim-plugin-zoomwin

Change Logs

* Tue Nov 16 2021 Jiri Slaby <jslaby@suse.cz>
- update
  * NERDcommenter_version  2.5.2
  * NERDtree_version       6.10.16
  * supertab_version       2.1
  * zoomwin_tag            24@1
- add
  * vim-markdown           2.0.0+20200714
- clean up the spec, esp. the post/postup part using macro.
* Thu Sep 30 2021 Jiri Slaby <jslaby@suse.cz>
- update
  * align_version          37.43
  * fugitive_version       3.4
  * tlib_version           1.27
  * tselectfiles_version   0.11
- cleanup the spec and use URLs in Sources
- remove vim-fugitive-Remove-unnecessary-complete-on-command-with-no-argum.patch
  (it's upstream)
* Tue Aug 03 2021 Jiri Slaby <jslaby@suse.cz>
- update vim-fugitive to 3.3
- add vim-fugitive-Remove-unnecessary-complete-on-command-with-no-argum.patch
* Mon Apr 26 2021 Jiri Slaby <jslaby@suse.cz>
- Fix bufexplorer's source link.
* Fri Apr 23 2021 Jiri Slaby <jslaby@suse.cz>
- Update several plugins
  * bufexplorer to 7.4.21
  * calendar to 2.5
- add file-line-Fix-other-plugins-loading.patch
* Tue Apr 13 2021 Jiri Slaby <jslaby@suse.cz>
- Sort _service and .spec file
* Mon Apr 12 2021 Jiri Slaby <jslaby@suse.cz>
- Add file-line-1.0+20161020
- Update several plugins
  * vim-latex to 1.10.0+20210323 (we use git snapshots as suggested
    on the project page)
  * vimplugin-fugitive to 3.2
  * vimplugin-gnupg to 2.7.1 (we provide also .asc to allow archive
    verification)
  * vimplugin-taglist to 4.6
* Mon Nov 11 2019 Johannes Thumshirn <jthumshirn@suse.com>
- Update vim-plugin-fugitive to upstream version 3.1
* Wed Sep 11 2019 Olav Reinert <seroton10@gmail.com>
- add vim-plugin-salt 0.0.1
* Mon Feb 26 2018 dsterba@suse.cz
- add plugin for neomutt config files
Version: 7.2.22-bp150.2.3
* Tue Feb 27 2018 dsterba@suse.cz
- add plugin for neomutt config files
* Mon Apr 10 2017 tchvatal@suse.com
- Fix showmarks script wrt bsc#905770:
  * add patch from upstream https://github.com/vim-scripts/ShowMarks/pull/3:
    + showmarks-signs.patch
* Tue Aug 16 2016 astieger@suse.com
- Remove vim-plugin-ag: deprecated upstream, license issues. The
  fork source vim-plugin-ack can be used:
    let g:ackprg = 'ag --vimgrep'
* Sat Jun 25 2016 sebix+novell.com@sebix.at
- Update vim-plugin-gnupg to upstream version 2.6
* Thu Apr 28 2016 nicolas.bock@suse.com
- Add vim-plugin-fugitive
* Tue Feb 23 2016 astieger@suse.com
- update vim-plugin-ack to 1.0.9:
  * Fix location list and layout of quickfix when using Dispatch
  * Fix the quick help overlay clobbering the list mappings
  * Fix :AckFile when using Dispatch
  * Restore original 'makeprg' and 'errorformat' when using Dispatch
  * Arrow keys also work for auto-preview
  * Internal refactoring and clean-up
- update vim-plugin-ag to current git head:
  * can now work on project root
  * prevent empty searches
- update vim-plugin-editorconfig to 0.3.3
* Fri Dec 11 2015 astieger@suse.com
- add vim-plugin-editorconfig supporting EditorConfig
* Fri Nov 27 2015 astieger@suse.com
- for spec.snippets, replace defunct _serv ce referencing
  gitorious.org with plain gitlab URL
* Mon Jun 08 2015 astieger@suse.com
- add plugin for ack
- add plugin for ag a.k.a. the_silver_searcher
* Fri Sep 12 2014 mrueckert@suse.de
- downgrade the requires to a recommends.
* Fri Sep 12 2014 mrueckert@suse.de
- adapt requires in the -rails subpackage to the rubygem() syntax.
* Tue Sep 02 2014 coolo@suse.com
- fix license for spdx 1.2
* Thu Feb 20 2014 puzel@suse.com
- update vimwiki plugin to 2.1
- most important changes:
  - no more CamelCase links
  - markdown support
  - syntax changes
- for full changelog visit:
  http://www.vim.org/scripts/script.php?script_id=2226
* Tue Feb 11 2014 coolo@suse.com
- change WTFPL license to new spdx.org spelling
* Wed Nov 07 2012 puzel@suse.com
- Update quilt plugin to 0.9.7
  - fix problem with line history
- drop quilt-plugin-fix-autocmds.patch
* Sat Nov 03 2012 puzel@suse.com
- quilt-plugin-fix-autocmds.patch (bnc#746971)
* Wed Oct 10 2012 puzel@suse.com
- gitdiff plugin is GPLv2 - fix license string
* Tue Oct 02 2012 puzel@suse.com
- drop matchit plugin - it's part of standard vim installation
* Wed Sep 26 2012 puzel@suse.com
- Fix licenses for calendar, snipmate, project, matchit and matrix
  plugins (bnc#768672)
- fix link to spec.snippets in _service
* Wed Jun 27 2012 puzel@suse.com
- fixed some license strings (bnc#768672)
- updated following plugins to latest versions:
  o align
  o bufexplorer
  o calendar
  o colorsel
  o diffchanges
  o nerdcommenter
  o nerdtree
  o tlib
  o tselectbuffer
  o zoomwin
  o latex
  o rails
- drop colorsel-disable-nogui-warning-error.patch (upstream)