Package Release Info

vala-panel-extras-0.1.9-bp153.1.20

Update Info: Base Release
Available in Package Hub : 15 SP3

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

vala-panel-extras-battery
vala-panel-extras-gtop
vala-panel-extras-lang
vala-panel-extras-volume
vala-panel-extras-weather
vala-panel-extras-xkb
vala-panel-extras-xkb-flags

Change Logs

Version: 0.1.5-bp150.2.4
* Wed Apr 05 2017 sor.alexei@meowr.ru
- Update to version 0.1.5:
  * No changelog available.
- Remove the glib-2.0.vapi hack.
- Remove vala-panel-extras-fix-gquarks.patch,
  vala-panel-extras-fix-xkb-build.patch: fixed upstream.
* Sat Apr 01 2017 sor.alexei@meowr.ru
- Add vala-panel-extras-0.1.4-vala-0.36.patch: Fix build with
  Vala 0.36 and newer.
* Sat May 07 2016 sor.alexei@meowr.ru
- Add vala-panel-extras-fix-gquarks.patch: fix build by using int
  instead of GQuark.
- Fix build by using upstream glib-2.0.vapi.
* Thu Aug 20 2015 sor.alexei@meowr.ru
- Add vala-panel-extras-fix-xkb-build.patch: fix XKB module build
  in some conditions.
* Fri Jun 19 2015 sor.alexei@meowr.ru
- Initial package.
Version: 0.1.9-bp152.1.1
* Sat Feb 22 2020 Alexei Sorokin <sor.alexei@meowr.ru>
- Add vala-panel-extras-fix-build.patch: fix build
  (commits 6fb4639f, e0fce753).
- Depend on vala-cmake-modules.
- Drop support for old openSUSE versions.
* Mon Aug 27 2018 Alexei Sorokin <sor.alexei@meowr.ru>
- Update to version 0.1.9:
  * Build with new GWeather.
  * Fix Vala 0.40 warnings.
  * Update Chinese translation.
- Remove Fix-build-new-libgweather.patch,
  vala040-fixup-warnings.patch: fixed upstream.
* Wed May 02 2018 bjorn.lie@gmail.com
- Update to version 0.1.8:
  + Volume applet got beep on change volume.
- Changes from version 0.1.7:
  + Even more fixes for vala 0.36.
- Changes from version 0.1.6:
  + Fixes for vala 0.36.
- Add pkgconfig(libcanberra-gtk3) BuildRequires: New dependency.
- Drop vala-panel-extras-0.1.4-vala-0.36.patch: Fixed upstream.
- Add vala040-fixup-warnings.patch: Fix warnings with vala 0.40.
- Add Fix-build-new-libgweather.patch: Fix build with new
  libgweather.
- Drop no longer needed post(un) handling of
  glib2_gsettings_schema_post(un).
- Run spec-cleaner, modernize spec.
- Add fdupes BuildRequires and pass fdupes macro, remove duplicates
  and silence rpmlint.