Package Release Info

uhd-3.9.7-bp153.1.24

Update Info: Base Release
Available in Package Hub : 15 SP3

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

libuhd003
uhd-devel
uhd-doc
uhd-firmware
uhd-udev

Change Logs

Version: 3.9.7-bp150.1.3
* Sat Jan 13 2018 mardnh@gmx.de
- Force usage of python2 during build
* Wed Jan 03 2018 mardnh@gmx.de
- Adjust _constraints to set required memory to 6Gb
* Thu Dec 28 2017 wk@ire.pw.edu.pl
- fixed build with boost-1.66
  patch uhd-fix-for-boost-1_66.patch backported from git
* Fri Jul 21 2017 wk@ire.pw.edu.pl
- Updated sources to version 3.9.7
- enabled GPSD support
* Thu May 04 2017 wk@ire.pw.edu.pl
- Force docutils to use python2 on Tumbleweed
* Fri Feb 03 2017 jengelh@inai.de
- Directly invoke ldconfig and don't suppress output from groupadd.
* Thu Feb 02 2017 adam.majer@suse.de
- use individual libboost-*-devel packages instead of boost-devel
* Tue Dec 13 2016 victhor.foster@gmail.com
- Add fix-for-armv6l-armv7l-build-failure.patch, adds -mfpu=neon compiler flag to package
  Fixes build failure on armv6l and armv7l architectures
* Sat Sep 03 2016 wk@ire.pw.edu.pl
- Update sources to version 3.9.5
* Sun Jul 03 2016 opensuse.lietuviu.kalba@gmail.com
- %pre script requires /usr/sbin/groupadd from "shadow" package
* Sat May 07 2016 wk@ire.pw.edu.pl
- Update sources to version 3.9.4
* Wed Mar 23 2016 wk@ire.pw.edu.pl
- Update sources to version 3.9.3
* Thu Dec 31 2015 wk@ire.pw.edu.pl
- Update sources to version 3.9.2
- Drop 0003-uhd-C-API-wrapper-fix-commit-30f87afcba71a07.patch:
  included upstream
* Sun Dec 27 2015 mardnh@gmx.de
- Add patch for correctly installing the C-API header files
  * 0003-uhd-C-API-wrapper-fix-commit-30f87afcba71a07.patch
* Sat Sep 26 2015 wk@ire.pw.edu.pl
- Update sources to version 3.9.1
- arm-neon.patch patch removed
* Thu Sep 10 2015 wk@ire.pw.edu.pl
- Update sources to version 3.9.0
* Tue Aug 18 2015 wk@ire.pw.edu.pl
- Update sources to version 3.8.5
* Wed Aug 12 2015 schwab@suse.de
- arm-neon.patch: don't use 32-bit arm code on 64-bit arm
* Sat Jun 20 2015 dmitry_r@opensuse.org
- Add _constraints to set required memory to 3Gb
* Sat May 16 2015 wk@ire.pw.edu.pl
- Update sources to version 3.8.4
Version: 3.9.7-bp152.4.56
* Mon Feb 03 2020 Dominique Leuenberger <dimstar@opensuse.org>
- BuildRequire pkgconfig(udev) instead of udev: allow OBS to
  shortcut through -mini flavors.
* Sat Mar 23 2019 Wojciech Kazubski <wk@ire.pw.edu.pl>
- Fixed build for Boost 1.69
* Fri Dec 28 2018 mardnh@gmx.de
- Disable support for GPSD in uhd for now.
  gps support is not yet adapted to the latest gpsd API.
* Tue May 29 2018 adam.majer@suse.de
- fixed build with Boost 1.67 (bsc#1089820)
  uhd-fix-for-boost-1_67.patch
- drop _constraints and use memory-constraints package instead.
- re-enabled package tests