Package Release Info

scap-workbench-1.2.1-bp152.1.7

Update Info: Base Release
Available in Package Hub : 15 SP2

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

scap-workbench
scap-workbench-doc

Change Logs

Version: 1.1.5-bp150.2.3
* Sat Dec 30 2017 jengelh@inai.de
- Fix RPM groups. Optimize unnecessary subshell calls.
* Wed Sep 20 2017 zaitor@opensuse.org
- Update to version 1.1.5:
  + Highlights: Tri-state checkboxes in Tailoring Window.
  + Bugfixes:
  - Fixed remote host and port being cleared when scan starts
  - Fixed formating of Profile html description in Tailoring Window
  - Fixed oscap message "Downloading ... ok" appearing as an error
  + Other improvements:
  - Fixed tab order of widgets in main window.
  - Load Content as the default button of the SSG integration
    dialog.
  - New validation of the customization file name.
- Drop obsolete and unused conditional libwebkitgtk-devel and
  libwebkit-devel BuildRequires, this dependency was dropped in
  version 0.0.8 upstream.
* Mon Jan 16 2017 meissner@suse.com
- Update to 1.1.4
  - Highlights
    Fix --fetch-remote-resources warning with older openscap
  - Bugfixes
    Check capabilities of oscap with propper arguments
  - Other improvements
    Show number of selected rules in profile listing
    Enable High DPI mode in MacOSX builds
    Remove fixed sizes of checkboxes and Port label
    Improve UX of recent remote machine history list
  - See https://github.com/OpenSCAP/scap-workbench/issues?q=milestone%3A1.1.4 for more details
- Update to 1.1.3
  - Highlights
    UX improvements
    Improved error message when scanning a remote machine in which openscap-scanner is not installed
  - Bugfixes
    Fixed search on disabled item
    Fixed multi benchmark tailoring use case
    Fixed a bug that caused tailored profiles to have titles duplicated
    Fixed path of tailoring file in dry run output
    Fixed fetch remote resources warning
  - Other improvements
    Added a helper script that builds SCAP Workbench for OSX
    Now Workbench doesn't allow edit of values with prohibitedChanges attribute
    Added --version and --help command line options
    Improved workflow of dry run execution
  - See https://github.com/OpenSCAP/scap-workbench/issues?q=milestone%3A1.1.3 for more details
- Update to 1.1.2:
  - New feature: "dry-run" - see which oscap arguments you have to use to do the same evaluation as SCAP Workbench as it is currently set.
  - Minor bugfixes:
    fixed checklist combobox when a datastream with multiple benchmarks is opened
    fixed minor licensing issues
  - See https://github.com/OpenSCAP/scap-workbench/issues?q=milestone%3A1.1.2 for more
* Mon Oct 12 2015 kkaempf@suse.com
- Update to 1.1.1
  Bugfix release
* Mon Oct 12 2015 kkaempf@suse.com
- take ownership of /usr/share/polkit-1*
* Thu Mar 26 2015 meissner@suse.com
- updated to 1.1.0
  Shiny new major release of SCAP Workbench. A lot of UX improvements
  and many new exciting features including a much better SCAP Security
  Guide integration. Downstreams are now encouraged to depend on
  scap-security-guide.
* Thu Feb 05 2015 kkaempf@suse.com
- Require libqt4-devel >= 4.8
* Fri Jan 09 2015 meissner@suse.com
- version 1.0.3
  This is a maintenance release with many bugfixes, usability improvements
  and documentation fixes. All users are recommended to update.
  See https://fedorahosted.org/scap-workbench/query?group=status&milestone=1.0.3
  for full list of changes.
- scap-workbench-0.8.6.patch: upstream
* Sat Feb 08 2014 kkaempf@suse.com
- fix path to bash, add scap-workbench-0.8.6.patch
* Sat Feb 08 2014 kkaempf@suse.com
- Initial version 0.8.6
Version: 1.1.5-bp151.4.3.1
* Thu Aug 29 2019 matthias.gerstner@suse.com
- add 0001-pkexec-avoid-potential-local-root-exploit-by-using-P.patch:
  security hardening as outlined in bsc#1084706.
Version: 1.2.1+git20210604.1fc6def-bp153.2.3.1
* Thu Jan 13 2022 Marcus Meissner <meissner@suse.com>
- require "ssh" at buildtime to enable remote mode. (bsc#1194604)
* Fri Jun 04 2021 Klaus Kämpf <kkaempf@suse.com>
- Update to 1.2.1+git20210604.1fc6def to fix Factory build
- drop 0001-Port-Qt5-deprecated-methods.patch (upstream)
* Wed Mar 25 2020 Christophe Giboudeaux <christophe@krop.fr>
- Update to 1.2.1. No changelog.
- Rebase 0001-pkexec-avoid-potential-local-root-exploit-by-using-P.patch
- Drop 0002-Qt5-deprecations.patch. Merged upstream
- Add 0001-Port-Qt5-deprecated-methods.patch
* Fri Oct 11 2019 Klaus Kämpf <kkaempf@suse.com>
- fix Qt5 deprecation warnings
  0002-Qt5-deprecations.patch
* Sat Apr 13 2019 Christophe Giboudeaux <christophe@krop.fr>
- Update to 1.2.0. Changes since 1.1.5:
  * ported from Qt4 to Qt5
  * UX improvements
  * Generate bash and Ansible remediation roles from profiles
  * Generate bash and Ansible remediation roles from results after
    scanning
  * Fixed a short integer overflow when using ssh port numbers
    higher than 32k
* Thu Jul 26 2018 matthias.gerstner@suse.com
- 0001-pkexec-avoid-potential-local-root-exploit-by-using-P.patch:
  harden and sanitize the pkexec wrapper (bsc#1084706).