Package Release Info

rubygem-ruby-openid-2.7.0-bp154.1.20

Update Info: Base Release
Available in Package Hub : 15 SP4)

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

ruby2.5-rubygem-ruby-openid
ruby2.5-rubygem-ruby-openid-doc
ruby2.5-rubygem-ruby-openid-testsuite

Change Logs

Version: 2.7.0-bp150.2.4
* Mon Feb 05 2018 jmassaguerpla@suse.com
- fix license to match spdx identifiers https://spdx.org/licenses/
* Fri Mar 06 2015 coolo@suse.com
- updated to version 2.7.0
* Fri Feb 06 2015 coolo@suse.com
- updated to version 2.6.0
  * More safely build filenames - 1c4a90630b183e7572b8ab5f2e3a3e0c0fecd2c7
  See https://github.com/openid/ruby-openid/pull/80
  * The session serializer of Rails4.1 is json - b44a1eb511dec3be25a07930121bc80cacec0f1c
  * Handle boolean value to fix signature issue - d65076269b77754da7db6e4b189edeeb9201600d
  See https://github.com/openid/ruby-openid/pull/76
* Mon Oct 13 2014 coolo@suse.com
- adapt to new rubygem packaging
* Thu Feb 06 2014 coolo@suse.com
- updated to version 2.5.0
  * Allow expecting a parameter to be nil during return_to verification - 708e992ab3e6c26d478283fc11faa6a0a74bfec0
  * Fixed missing XRDS HTTP header in sample provider - dc15fa07fd59fdcf46d659cce34c6ef7a6768fde
* Mon Sep 23 2013 coolo@suse.com
- updated to version 2.3.0
  * Deprecated Ruby 1.8 support - 0694bebc83de0313cfef73a5d0ffd9a293ae71a0
  * Fixed encoding errors in test suite - 7ac8e3978f9c733bd5ee8d6b742b515b5427ded2
  * Be aware when using Hash or Array as default value for unknown Hash keys - #58
  * Stop overwriting String#starts_with? and String#ends_with? if defined - #55
  * Ignore Associations For OpenID2 (Google's Security Bug Fix) - #53
  * Change "oauth" to "ui" in variable name in the UI extension - #52
  * Eliminating runtime warnings - #50 #56
  * Upgrade example Rails provider/consumer app to Rails 3 - #49
* Tue Mar 05 2013 coolo@suse.com
- updated to version 2.2.3
  * Fixed 'invalid byte sequence in UTF-8' error in parse_link_attrs - 0f46921a97677b83b106366c805063105c5e9f20
  * Fixed license information in gemspec - f032e949e1ca9078ab7508d9629398ca2c36980a
  * Update starts/ends_with? to handle nil prefix - beee5e8d1dc24ad55725cfcc720eefba6bdbd279
* Sun Oct 28 2012 coolo@suse.com
- updated to version 2.2.2
  * Limit fetching file size & disable XML entity expansion - be2bab5c21f04735045e071411b349afb790078f
  Avoid DoS attack to RPs using large XRDS / too many XML entity expansion in XRDS.
  * Make bundle exec rake work - 2100f281172427d1557ebe76afbd24072a22d04f
  * State license in gemspec for automated tools / rubygems.org page - 2d5c3cd8f2476b28d60609822120c79d71919b7b
  * Use default-external encoding instead of ascii for badly encoded pages - a68d2591ac350459c874da10108e6ff5a8c08750
  * Colorize output and reveal tests that never ran - 4b0143f0a3b10060d5f52346954219bba3375039
* Mon Oct 01 2012 coolo@suse.com
- updated to version 2.2.1
* Wed Aug 01 2012 coolo@suse.com
- updated to version 2.2.0
* Tue Jan 11 2011 aduffeck@novell.com
- update to version 2.1.8
* Fri Jun 11 2010 mrueckert@suse.de
- use rubygems_requires macro
* Sat Nov 14 2009 mrueckert@suse.de
- update to version 2.1.7
* Fri Jan 16 2009 mrueckert@suse.de
- update to version 2.1.4
* Tue May 22 2007 mrueckert@suse.de
- update to version 1.1.4
* Sun Sep 24 2006 mrueckert@suse.de
- update to version 1.1.3:
  Bugfix release which fixes a problems related to wildcard
  trustroots on the server, and gracefully handling repeated OpenID
  responses on the consumer.
* Fri Aug 25 2006 mrueckert@suse.de
- update to version 1.1.2:
  Minor bugfix release: gracefully handle empty trust roots in
  OpenID::Server, Updated yadis library dependancy.
* Tue Aug 22 2006 mrueckert@suse.de
- update to version 1.1.1: (changes since 1.0.2)
  This is a bugfix release, and also introduces the ability to
  verify i-names.  Users of the library may now use the OpenID
  protocol to verify both URL and XRI based identifiers.