Package Release Info

qtkeychain-qt5-0.9.1-bp153.1.27

Update Info: Base Release
Available in Package Hub : 15 SP3

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

libqt5keychain1
libqt5keychain1-64bit
libqt5keychain1-lang
qtkeychain-qt5-devel

Change Logs

Version: 0.13.2-bp154.1.198
* Sat Feb 05 2022 Christophe Giboudeaux <christophe@krop.fr>
- Use the qt6 macros to build qtkeychain-qt6
* Wed Feb 02 2022 Christophe Giboudeaux <christophe@krop.fr>
- Add patch to restore compatibility with CMake 3.16:
  * 0001-Define-a-poper-exported-CMake-target-instead-of-intr.patch
* Tue Dec 14 2021 Christophe Giboudeaux <christophe@krop.fr>
- Fix qtkeychain users on Leap.
* Fri Dec 10 2021 Christophe Giboudeaux <christophe@krop.fr>
- Update to 0.13.2
  * Linux: Require libsecret if not explicitly disabled
  * Unify implementations for macOS and iOS
  * CMake: lots of fixes
  * KWallet: Fix deletion of entries
  * CMake: Deprecate QTKEYCHAIN_STATIC in favor of
    BUILD_SHARED_LIBS
- Drop the unneeded baselibs.conf.
* Sat Jan 09 2021 Fabian Vogt <fabian@ritter-vogt.de>
- %lang_package doesn't handle -r and -n parameters at the same
  time, expand it manually
* Wed Dec 30 2020 Christophe Giboudeaux <christophe@krop.fr>
- Add qtkeychain-qt6.
- Add the missing libsecret build dependency to qtkeychain-qt5.
* Tue Dec 29 2020 Fabian Vogt <fabian@ritter-vogt.de>
- Use %find_lang
* Tue Dec 29 2020 Dirk Müller <dmueller@suse.com>
- update to 0.12.0:
  * Add Qt 6 support, drop Qt 4 support
  * Require C++11
  * Add Android support (Mathias Hasselmann)
  * Build system fixes
* Wed Feb 26 2020 Christophe Giboudeaux <christophe@krop.fr>
- Update to 0.10.0:
  * Detect XFCE desktop correctly
  * Fix build with Qt 5.12.x
  * translations update
- Drop upstream patches:
  * 0001-On-Unix-systems-shared-libraries-have-a-abi-version.patch
  * 0002-Detect-XFCE-desktop-correctly.patch
  * 0003-Generate-Qt-5.12.1-compatible-qt_Qt5Keychain.pri.patch
* Mon Jun 17 2019 Fabian Vogt <fabian@ritter-vogt.de>
- Add fixes from git master:
  * 0001-On-Unix-systems-shared-libraries-have-a-abi-version.patch
  * 0002-Detect-XFCE-desktop-correctly.patch
  * 0003-Generate-Qt-5.12.1-compatible-qt_Qt5Keychain.pri.patch (boo#1130608)
Version: 0.7.0-bp150.2.4
* Tue Jul 12 2016 hrvoje.senjan@gmail.com
- Update to 0.7.0
  * Bump SO version due to 0.6 being binary-incompatible
    qto previous releases
- Changes since 0.6.2
  * KWallet: Fixes a crash when storing passwords, seen on Debian/KDE4
- Changes since 0.6.1
  * Fix KWallet not working (regressions in 0.6.0)
- Changes since 0.6.0
  * Added support for the Windows Credential Store
* Tue Feb 09 2016 cgiboudeaux@gmx.com
- Update to 0.5.0
  Added support for KWallet5
* Wed Oct 22 2014 hrvoje.senjan@gmail.com
- Activate qtkeychain-qt5 package
Version: 0.9.1-bp151.1.6
* Mon Oct 22 2018 Jan Engelhardt <jengelh@inai.de>
- Trim fill words from description. Ensure neutrality of it, too.
* Mon Oct 22 2018 Christophe Giboudeaux <christophe@krop.fr>
- Update to 0.9.1. Changes since 0.8.0:
  * Only require QtLinguist if building translations
  * Fall back on libsecret if kwallet is not available
  * Secret: Don't match the schema name
* Sat May 26 2018 christophe@krop.fr
- Update to 0.8.0:
  * Buildsystem improvements.
  * Enable C++11 support for Qt >= 5.7.
  * Doxygen documentation.
  * Libsecret support.