Package Release Info

python-ndg-httpsclient-0.5.1-bp154.1.29

Update Info: Base Release
Available in Package Hub : 15 SP4 (BETA)

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

python3-ndg-httpsclient

Change Logs

Version: 0.4.0-bp150.2.4
* Thu Aug 24 2017 jmatejek@suse.com
- singlespec auto-conversion
* Fri Jun 12 2015 t.gruner@katodev.de
- Initial Version 0.4.0
  * Made dual compatible with Python 2 / 3.
  0.3.3
---
  * Fix to add in AnotherName for ``subjectAltNames`` field - added for support for CACert issued
  certs (thanks to Gu1).
  * Fix to HTTP Basic Auth option for ``ndg.httpsclient.utils.main``
  * Fix to ``ServerSSLCertVerification`` so that it can pass a function-based callback instead of using ``__call__``. In newer versions of OpenSSL (>= 0.14) the latter failed because of a request for ``__name__`` attribute.
  0.3.2
---
  * Fix to SubjectAltNames support check - should only be enabled if pyasn1 is
  installed.
  * Fix to open_url: HTTP Request object was being created inside if headers is
  None block - now corrected to create regardless.
  * Added http basic auth support to script. (Thanks to Willem van Engen)
  0.3.1
---
  * extended utils functions to support keyword for passing additional urllib2
  handlers.
  0.3.0
---
  * Added ndg.httpsclient.utils.fetch_stream_from_url function and added
  parameter for data to post in open_url and fetch_* methods.
  * fix to ndg.httpsclient.utils module _should_use_proxy and open_url functions
  0.2.0
---
  * added support for SSL verification with subjectAltNames using pyasn1
  * fixed minor bug - SSL cert DN prefix matching
  0.1.0
---
  Initial release
Version: 0.5.1-bp152.1.8
* Sun Jun 02 2019 Jan Engelhardt <jengelh@inai.de>
- Use noun phrase in summary.
* Wed May 29 2019 Marketa Calabkova <mcalabkova@suse.com>
- update to version 0.5.1
  0.5.*
  * Drop support for EOL Python 2.6 and 3.3
  * Updated SSL Context objects to default to TLS 1.2
  * Fix to Subject Alternative Name handling to allow for
    certificates with more than 64 names (max now 1024).
  0.4.*
  * Fix to ndg namespace package warning issue
  * Minor fix for installation: set minimum release for pyasn1
  * Fix to bug in ndg.httpsclient.utils.open_url - duplicate open call.
  * Moved LICENSE file into package
* Tue Dec 04 2018 Matej Cepl <mcepl@suse.com>
- Remove superfluous devel dependency for noarch package