Package Release Info

python-ldap-3.1.0-bp151.2.1

Update Info: openSUSE-2020-337
Available in Package Hub : 15 SP1 Update

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

python2-ldap

Change Logs

* Mon Dec 10 2018 Tomá? Chvátal <tchvatal@suse.com>
- Reduce the runtime dependencies to match the actual needs
  * User can use either openldap or 389-ds or anything else
- Run the tests on the package
- Fix the fdupes call
* Fri Dec 07 2018 Tomá? Chvátal <tchvatal@suse.com>
- Add this package to SLE wrt fate#325747
- Do not add version dependency to devel requirement
Version: 3.0.0b4-bp150.2.4
* Thu Jan 18 2018 fbergmann@suse.com
- update to upstream release 3.0.0b4:
  - Adds support for Python 3.4+
  - Adds support for `bytes_mode`
  - Idiotmatic python code changes
  - Adds testing for `pypy`
  - Fixes/enhances tests
- Remove python-ldap.keyring and python-ldap-%{version}.tar.gz.asc:
  There is no signature provided for the new upstream tarball
* Mon Nov 20 2017 michael@stroeder.com
- update to upstream release 2.5.2
  Changes since 2.5.1:
  * code-cleaning in setup.py
  Modules/
  * PyBytes_ instead of PyString_ and added PyInt_FromLong compat macro
  * moved code from version.c to ldapmodule.c
  * removed obsolete back-ward compability constants from common.h
  * build checks whether LDAP_API_VERSION is OpenLDAP 2.4.x
  * _ldap.__author__ and _ldap.__license__ also set from ldap.pkginfo
  * assume C extension API for Python 2.7+
  Lib/
  * removed all dependencies on modules string and types
  * removed use of .has_key()
  * removed class ldap.ldapobject.NonblockingLDAPObject
  * new global constant ldap.LIBLDAP_API_INFO
  * right after importing _ldap there is a call into libldap to initialize it
  * method .decodeControlValue() of SSSResponseControl and VLVResponseControl
  does not set class attribute result_code anymore
  * always use bytes() for UUID() constructor in ldap.syncrepl
  * module ldif now uses functions b64encode() and b64decode()
  * fixed pickling and restoring of ReconnectLDAPObject
  * more modules with PEP-8 compliance
  * ldap.ldapobject split into module-package
  Tests/
  * scripts do not directly call SlapdTestCase.setUpClass() anymore
  * added LDIF test with folded, base64-encoded attribute
  * added more tests for sub-module ldap.dn
  * added tests for ldap.syncrepl (thanks to Karl Kornel)
* Sun Nov 12 2017 michael@stroeder.com
- update to upstream release 2.5.1
- adjusted BuildRequires to match upstream prerequisites
  Changes since 2.4.45:
  Mandatory prerequisites:
- Python 2.7.x
- pyasn1 0.3.7+ and pyasn1_modules 0.1.5+
  Modules/
  * removed unused code schema.c
  Lib/
  * ldap.__version__, ldap.__author__ and ldap.__license__ now
  imported from new sub-module ldap.pkginfo also to setup.py
  * Added safety assertion when importing _ldap:
  ldap.pkginfo.__version__ must match _ldap.__version__
  * removed stand-alone module dsml
  * slapdtest.SlapdObject.restart() just restarts slapd
  without cleaning any data
  * Compability changes for pyasn1 0.3.x or newer
  (thanks to Ilya Etingof and Christian Heimes)
  * The methods SSSResponseControl.decodeControlValue() and
  VLVResponseControl.decodeControlValue() now follow the coding
  convention to use camel-cased ASN.1 name as class attribute name.
  The old class names are still set for back-ward compability
  but should not be used in new code because they might be removed
  in a later release.
  * removed SSSRequestControl from ldap.controls.KNOWN_RESPONSE_CONTROLS
  Tests/
  * added explicit reconnect tests for ReconnectLDAPObject
* Mon Oct 09 2017 michael@stroeder.com
- update to upstream release 2.4.45
  * fixed error handling
* Thu Sep 07 2017 michael@stroeder.com
- update to upstream release 2.4.44
  * GIL fix
* Thu Sep 07 2017 michael@stroeder.com
- update to upstream release 2.4.43
  * SASL bind fix
* Mon Sep 04 2017 michael@stroeder.com
- update to upstream release 2.4.42
  * small enhancements to test suite
* Wed Jul 12 2017 michael@stroeder.com
- update to upstream release 2.4.41 (small LDIF parser enhancement)
* Tue Jun 27 2017 michael@stroeder.com
- update to upstream release 2.4.40 (small memleak fix)
* Wed May 31 2017 michael@stroeder.com
- update to upstream release 2.4.39
* Thu May 18 2017 jmatejek@suse.com
- provide python2-ldap to support singlespec packages
* Fri Apr 28 2017 michael@stroeder.com
- update to upstream release 2.4.38
* Thu Apr 27 2017 michael@stroeder.com
- update to upstream release 2.4.37
* Wed Feb 08 2017 michael@stroeder.com
- Update to upstream release 2.4.30
  (with compability fix for pyasn1 0.2.x)
* Wed Jan 25 2017 michael@stroeder.com
- Update to upstream release 2.4.29
- added python-ldap.keyring to validate upstream source signatures
* Fri Nov 18 2016 michael@stroeder.com
- Update to upstream release 2.4.28
* Mon Aug 01 2016 michael@stroeder.com
- Update to upstream release 2.4.27
* Sun Jul 24 2016 michael@stroeder.com
- Update to upstream release 2.4.26
- updated pypi source URL
* Tue Feb 23 2016 michael@stroeder.com
- Use HTTPS links
* Wed Feb 10 2016 michael@stroeder.com
- Aligned desciption with project's web site
- Removed obsolete stuff:
  * build flag -DLDAP_DEPRECATED
  * outdated URL in package description
  * removing of CVS files
Version: 3.1.0-3.2.20
* Mon Dec 10 2018 tchvatal@suse.com
- Reduce the runtime dependencies to match the actual needs
  * User can use either openldap or 389-ds or anything else
- Run the tests on the package
- Fix the fdupes call
* Fri Dec 07 2018 tchvatal@suse.com
- Add this package to SLE wrt fate#325747
- Do not add version dependency to devel requirement
* Tue Aug 14 2018 tchvatal@suse.com
- Require openldap2-client as some of the binaries are called
  on the runtime
* Tue Aug 07 2018 michael@stroeder.com
- update to upstream release 3.1.0:
  * Long-deprecated functions `ldap.open()` and `ldap.init()` are removed
  * `LDAPObject.compare_s()` and `compare_ext_s` return bool instead of 0 or 1
  * Tons of changes see CHANGES file