Package Info

python-flake8-future-import


__future__ import checker, plugin for flake8


Development/Languages/Python

A script to check for the imported __future__ modules to make it easier to have a consistent code base.

By default it requires and forbids all imports but it's possible to have certain imports optional by ignoring both their requiring and forbidding error code. In the future it's planned to have a “consistency” mode and that the default is having the import optional or required (not sure on that yet).

This module provides a plugin for flake8, the Python code checker.


License: MIT
URL: https://github.com/xZise/flake8-future-import

Categories

Releases

Package Version Update ID Released Package Hub Version Platforms Subpackages
0.4.5-bp151.1.3 info GA Release 2019-07-17 15 SP1
  • AArch64
  • ppc64le
  • s390x
  • x86-64
  • python2-flake8-future-import
  • python3-flake8-future-import
0.4.6-bp152.1.8 info GA Release 2020-04-17 15 SP2
  • AArch64
  • ppc64le
  • s390x
  • x86-64
  • python2-flake8-future-import
  • python3-flake8-future-import
0.4.6-bp153.1.17 info GA Release 2021-03-06 15 SP3
  • AArch64
  • ppc64le
  • s390x
  • x86-64
  • python2-flake8-future-import
  • python3-flake8-future-import