Package Release Info

plplot-5.15.0-bp152.2.8

Update Info: Base Release
Available in Package Hub : 15 SP2

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

libcsirocsa0
libcsironn0
libplplot17
libplplotada4
libplplotcxx15
libplplotfortran0
libplplotqt2
libplplotwxwidgets1
libqsastime0
plplot-common
plplot-devel
plplot-doc
plplot-driver-cairo
plplot-driver-ntk
plplot-driver-ps
plplot-driver-psttf
plplot-driver-svg
plplot-driver-xfig
plplot-driver-xwin
plplot-java
plplot-lua
plplot-python3-qt
plplot-tcltk-devel
plplot-tcltk-libs
plplot-wxwidgets
plplotada-devel
plplotcxx-devel
plplotfortran-devel
plplotqt-devel
plplotwxwidgets-devel
python3-plplot

Change Logs

* Mon Feb 24 2020 Atri Bhattacharya <badshah400@gmail.com>
- Re-enable csironn bindings for openSUSE >= 1550 as they build
  again (due to fixes to qhull package).
* Mon Feb 24 2020 olaf@aepfle.de
- add conditional for OCaml bindings, they depend on camlidl
- actually fix the OCaml bindings with plplot-ocaml.patch
- use autosetup, build verbose
* Tue Feb 04 2020 Dominique Leuenberger <dimstar@opensuse.org>
- Do not require libcsironn0 from the -devel package on
  suse_version>=1550, where this is no longer built.
* Fri Dec 13 2019 Atri Bhattacharya <badshah400@gmail.com>
- plplotqt-devel no longer Requires libqt4-devel, instead the
  appropriate Qt5 headers.
* Thu Dec 12 2019 Atri Bhattacharya <badshah400@gmail.com>
- Disable libcsironn on openSUSE >= 1550 to prevent build
  failures.
- Fix shapelib dependency: BuildRequires: pkgconfig(shapelib)
  instead of BuildRequires: shapelib; install additional shapelib
  files as part of plplot-common.
* Thu Sep 26 2019 olaf@aepfle.de
- Add ExclusiveArch, based on build_ada in gcc.spec
* Wed Jun 05 2019 Luigi Baldoni <aloisio@gmx.com>
- Update to version 5.15.0
  * Bug fixes
  * Update PLplot to be consistent with modern free software
  * Rewrite the configuration of the INSTALL_RPATH target
    property
  * Rewrite the rpath configuration of traditionally built
    examples
  * Factor the PLplot export files
  * Introduce symbolic constants in our color-map routines
  * New implementation of the range checks for the validity of
    cmap0 and cmap1 user input
  * New implementation of the -bg command-line option
  * Implement ctest for the build system of the installed
    examples
Version: 5.13.0-bp150.1.3
* Tue May 08 2018 badshah400@gmail.com
- plplot-devel should not depend on shared libs which are not
  built: %{csirocsa_shlib} and %{csironn_shlib} on certain archs.
* Mon May 07 2018 guillaume.gardet@opensuse.org
- Handle aarch64, ppc64 and ppc64le, not only x86_64 for libs
* Thu Apr 26 2018 badshah400@gmail.com
- Fix building for i586 by packaging x86_64-only libraries only
  for the latter arch.
* Fri Feb 16 2018 badshah400@gmail.com
- Remove python3-base from Requires for %{name}-tcltk; it is
  unneeded in light of python(abi) getting pulled in
  automatically.
* Mon Feb 12 2018 badshah400@gmail.com
- Replace even more python2 Requires with python3 ones; this
  finally fixes build failures on openSUSE:Leap:15.0.
* Mon Feb 12 2018 badshah400@gmail.com
- Swap leftover python2 Requires for explicitly python3 ones,
  rename python package to python3-plplot.
* Fri Dec 01 2017 badshah400@gmail.com
- Switch to using explicit python3 BuildRequires (plplot is
  "unresolvable" for openSUSE <= 1320 anyway); adapt file lists
  accordingly.
- Drop conditionals referring to old openSUSE versions <= 1320.
* Fri Dec 01 2017 dimstar@opensuse.org
- Drop legacy dependencies: pkgconfig(gnome-python-2.0) and
  pkgconfig(pygtk-2.0) are not in use.
* Wed Nov 29 2017 badshah400@gmail.com
- Fix License tag in specfile for plplot-octave subpackage: While
  everything else is licensed as LGPL-2.1+, the Octave bindings
  are licensed as GPL-2.0+.
* Sat Nov 11 2017 badshah400@gmail.com
- Drop BuildRequires on libgnomui and libgnomeprintui, as they are
  not really required any more (boo#1067727).
- Change hashbangs for python based examples so that they refer
  directly to the python binary instead of doing so via env.
* Wed Oct 04 2017 fstrba@suse.com
- Remove the stale gcc-java dependency, since gcc-java is bound to
  go soon and it is really not needed for building here
* Sat Aug 26 2017 badshah400@gmail.com
- Update to version 5.13.0:
  * Bug fixes.
  * The Python binding and examples now work for both Python 2 and
    3.
  * Change the Fortran naming convention.
  * Fix many "space in prefix" issues.
  * Complete rewrite of IPC between -dev wxwidgets and wxPLViewer.
  * Implement a new Windows GDI (wingdi) device driver.
  * Implement new Python extension module to support pytkdemo.
  * Fix OCaml inconsistencies for example 8.
  * Improve the implementation of the OCaml binding.
- Add shapelib BuildRequires for added features.
- Rename fortran shared lib and devel package in keeping with
  corresponding shared object naming changes.
- Use ctest for the check section. This allows the disabling of
  tests that either fail because of issues with the test codes
  themselves (octave), or because of lack of a full Xserver (Qt
  tests).
* Fri Jun 16 2017 alarrosa@suse.com
- Add LDFLAGS=-fPIC to fix the ada compiler test to link successfully
  and enable the generation of ada bindings in Factory.
* Sat Feb 11 2017 jengelh@inai.de
- Remove Requires(post) since there is not even a %post section.
- Trim descriptions for size, fix wrong summaries.
* Tue Feb 07 2017 badshah400@gmail.com
- Switch to building with Qt5 instead of Qt4.
- Add BuildRequires on qhull, this generates a new shared lib
  now packaged as %{csironn_shlib}.
- Drop unused cmake variables.
- Rename devel pkgs to follow their corresponding shared library
  nomenclature.
- Split out wxPLViewer into its own subpackage, which is now
  called %{name}-wxwidgets (the shared lib which was using this
  name previously has been renamed in keeping with shlib policy).
- Drop %{name}-rpmlintrc file, as it is no longer needed.
- Since version 5.12.0 plplot's fortran bindings depend on
  gcc-fortran >= 6.0.
* Mon Jan 30 2017 badshah400@gmail.com
- Update to version 5.12.0:
  * Bug fixes.
  * Rewrite the CMake Ada language support.
  * Rewrite the Fortran binding.
  * Supply old Fortran binding and examples option.
  * Backwards incompatibilities introduced by the new Fortran
    binding.
  * Examples reworked for the -DPL_DOUBLE=OFF case.
  * Changes to our Ada bindings and examples.
  * Changes to our tclmatrix library.
  * Backwards-incompatible changes to our Tcl/Tk bindings and
    examples.
  * Substantial rewrite of the DocBook documentation.
  * Default page size consistency.
  * Updated D language support.
  * Modernized build-system support for Qt4 and Qt5.
  * Implemented support for pyqt5.
  * Addressed -DPL_DOUBLE=OFF issues.
  * Replaced "Lena" with "Chloe".
  * Removed trailing blanks on most text files in our source tree.
  * Make our wxwidgets find module consistent with the official
    version for CMake-3.7.1.
  * Introduction of two new generic pointer types to help protect
    against a planned future C API breakage.
  * Introduction of additional self-describing names for the types
    of arguments used in our C API.
  * Implement submission of dashboards to the <my.cdash.org> cdash
    server.
  * Substantial update and rename of the Python examples.
  * Linux efficiency improvements for the wxwidgets device driver.
- Drop plplot-cmake36-pkg_check_pkgconfig_macro.patch: upstreamed.
- Rebase plplot-5.9.9-ada-pic.patch for updated version.
- Fix timestamp on previous changelog entry.
- Back to installing plplot.pc by default instead of plplot-c.pc.
- Rename plplot-fortran to libplplotf95-%{sover} as it now
  contains a single shared lib.
- Apply shared library packaging guidelines wherever appropriate;
  remove corresponding %{name}-rpmlintrc snippet. Shared lib
  naming not applied to %{name}-tcltk-libs as all the SO in this
  package are always required together and have their SO numbers
  bumped in lock-step with each other.
- Rename %{name}-tcltk to %{name}-tcltk-libs.
- Except for the most basic drivers, package individual drivers in
  their own subpackages. Users need to individually install
  drivers they need, only mem and null drivers will be installed
  by default [with any of the devel pkgs, for example].
- Split out a %{name}-common package with the most basic drivers
  and common example files included; require it from all driver
  subpackage, and -devel packages.
* Sat Dec 31 2016 bwiedemann@suse.com
- build-fix: kill our Xvfb after use
* Fri Dec 09 2016 badshah400@gmail.com
- plplot.pc installs as plplot-c.pc with cmake >= 3.7.1 (now in
  openSUSE:Factory). Manually install a symlink plplot.pc to
  plplot-c.pc for consistency.
* Tue Oct 18 2016 badshah400@gmail.com
- Temporarily disable octave bindings as a workaround to build
  failures caused by octave's upgrade to version 4.2.0 in Factory.
* Sun Aug 14 2016 badshah400@gmail.com
- Enable tk bindings for all openSUSE versions; problem with
  Xvfb segfaulting that prevent building tk bindings for Leap:42.2
  and > 13.2 are worked around by passing the -noreset option to
  Xvfb (see boo#992429).
Version: 5.14.0-bp151.3.2
* Thu Apr 04 2019 Atri Bhattacharya <badshah400@gmail.com>
- Disable octave bindings until compilation against octave 5.1.x
  is supported.
* Fri Jan 25 2019 badshah400@gmail.com
- Update to version 5.14.0:
  * Update control of Python version
  * Rewrite the build-system logic for determining PYQT_SIP_DIR
    and PYQT_SIP_FLAGS
  * Implement plStatic2dGrid
  * Difference report default device changed from psc to svg
  * Resolve the remaining difference report issues
  * Improve command-line parsing
  * Cleanup of plmap
  * wxwidgets development status
  * First step toward using best CMake-3 practices for our build
    system
  * Update PLplot to be consistent with modern free software
  * Rewrite documentation of PLplot testing
  * Configure the ps and psttf device drivers just like all other
    device drivers
  * Bug fixes
- Drop plplot-fix-pkgconfig-checks.patch: upstreamed.
- Update shlib package names in keeping with upstream so versions.
- Enable octave bindings: compilation against 4.4.x has been fixed
  upstream.
* Fri Nov 30 2018 badshah400@gmail.com
- Add plplot-fix-pkgconfig-checks.patch: Fix pkg-config based
  checks for installed dependencies; patch taken from upstream
  git.
* Tue Jul 31 2018 badshah400@gmail.com
- Re-enable libcsirocsa and libscironn for i586: these are now
  building (go figure!)
* Tue Jun 05 2018 badshah400@gmail.com
- Disable octave bindings until compilation against octave 4.4 is
  sorted out; remove conditionals for setting octave_enabled as
  plplot is unresolvable against openSUSE < 1320 anyway.