Package Release Info

osc-plugin-collab-0.99-bp150.2.4

Update Info: Base Release
Available in Package Hub : 15

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

osc-plugin-collab

Change Logs

* Sat Nov 18 2017 zaitor@opensuse.org
- Update to version 0.99:
  + Support diff in meson buildsystem based packages.
* Sun Jul 21 2013 vuntz@opensuse.org
- Update to version 0.98:
  + Really port plugin to osc >= 0.140.1
  + Remove compatibility code with very old versions of osc
- Update Requires on osc to be versioned, since this now really
  only works with a recent version of osc.
* Mon Jul 01 2013 vuntz@opensuse.org
- Update to version 0.97:
  + Adapt code to osc's new plugin mechanism
* Thu Jan 10 2013 vuntz@opensuse.org
- Make build noarch.
- Fix build on Fedora/RHEL/CentOS/ScientificLinux:
  + Use Requires instead of Recommends since there are no
    Recommends there.
  + Package .pyc/.pyo files following the Fedora packaging policy
    (except for ScientificLinux, which doesn't do that).
* Mon Jan 07 2013 vuntz@opensuse.org
- Update to version 0.96:
  + Use new collab server.
* Thu Feb 23 2012 vuntz@opensuse.org
- Update to version 0.95:
  + Features:
  - Add ugly workaround to extract files from .tar.xz tarballs
  - Extract a diff of old and new configure.{ac,in} on update
  - Supersede old requests on buildsubmit/forward (unless
  - -no-supersede is used)
  + Fixes:
  - List requests that are in state 'review'
  - Improve todo performance
  - Use a cache when listing requests to improve performance
  - Fix crash in todo for packages with no upstream version
  - Use UTC for timezone in .changes entries
  - Change forwarded request description to the one from webui
  - Reset Release tag to 0 instead of 1 on updates
- Add Recommends for xz, so we can extract files from .tar.xz
  tarballs.
* Thu Jun 30 2011 vuntz@opensuse.org
- Update to version 0.94:
  + Features:
  - Add comments:
    . new 'comment', 'commentset', 'commentunset',
    'listcommented' commands to edit/view comments on packages
    . make 'todo' display packages with a comment, and add
  - -ignore-comments and --exclude-commented options to
    control this behavior
    . display comments after 'setup'/'update', unless
  - -ignore-comments is used
  - Add --details/--no-details options and collab_details config
    option (default to False) to display more details in 'todo'
  - 'update' command improvements:
    . Stop recompressing tarballs
    . Update Source tag in .spec on update to the tarball URL
    . Drop the "(Version XYZ)" part of the .spec header
  - Add --nobranch option to 'setup'/'update' commands
  - Unreserve the package after successful 'buildsubmit'
  - Add collab_do_package_tracking config option (default to
    False)
  + Fixes:
  - Make 'isreserved' work with multiple packages
* Tue Jun 28 2011 vuntz@opensuse.org
- Add quilt Recommends, as the plugin tells the user to use quilt
  to check patches.
- Update Url tag to point to new wiki page.
* Mon May 30 2011 vuntz@opensuse.org
- Update to version 0.93:
  + Fixes:
  - Handle httplib.BadStatusLine exception in build
  - Fix bug that was creating inconsistent state in checkout
* Fri Sep 10 2010 vuntz@opensuse.org
- Update to version 0.92:
  + Fixes:
  - Do not create empty helper files for NEWS/ChangeLog
  - Use updated build state names from OBS ('signing' was added,
    'expansion error' was renamed to 'unresolved')
  - Fix crash when list of reserved packages cannot be fetched
  - Make "osc collab forward" work with osc 0.129
* Sun Jan 17 2010 vuntz@opensuse.org
- Update to version 0.91:
  + Features:
  - Use the new scheduler state for build/buildsubmit to
    determine if the build status can be trusted or not.
  + Fixes:
  - Fix addition of osc-collab.* files to exclude glob.
* Mon Sep 14 2009 vuntz@opensuse.org
- This is the old osc-gnome plugin, split from osc-plugins-gnome,
  and renamed to osc-collab.
- Update to version 0.90:
  + Features:
  - Rename to osc collab and do not refer to anything GNOME
    specific anywhere
  - Support delta in non-link packages
  - Remove potential trailing slash from packages passed as args
    for convenience when used with autocompletion
  - Make the config options work per apiurl
  - Make it possible to use more than one repo at the same time
  - Display against which repo the build is done
  - Make setup/update branch from the devel project
  - Take into account the version in devel project for
    todo/update
  - Use openSUSE:Factory by default instead of GNOME:Factory
  - Autodetect default repository for builds
  - Add --nodevelproject option for the relevant commands
  - Add --version command
  + Fixes:
  - Improve upstream tarball basename detection in when the
    basename of the upstream tarball is not in the URL, but in
    the query fields
  - Fix warning about tag in Source always appearing
  - Do not crash with osc from trunk
  - Better handling of update when package is already updated
  - Fix listreserved to not list reservations from all projects
  - Substitute macros in %define lines too
  - Remove old cache files
  - Fix parsing of empty list options in ~/.oscrc
  - Improve help message
  - Code cleanups
Version: 0.103-bp152.4.3.1
* Sun Oct 06 2019 vuntz@opensuse.org
- Update to version 0.103:
  + Call time.tzset() after changing the timezone (#53)
  + Fix python2 compatibility (#49)
- Fix packaging for new versions of Fedora that don't include
  .pyc/.pyo files
* Wed Sep 11 2019 vuntz@opensuse.org
- Update to version 0.102:
  + Fix configuring on python3
  + Fix another str vs. bytes issue
* Fri May 03 2019 vuntz@opensuse.org
- Update to version 0.101:
  + Port to python3
  + Use https on the server
* Thu Mar 21 2019 vuntz@opensuse.org
- Update to version 0.100:
  + Support new location for oscrc in ~/.config/osc/
Version: 0.104+17-bp154.1.19
* Tue Sep 28 2021 dimstar@opensuse.org
- Update to version 0.104+17:
  * [upstream] track some more gnome packages
* Wed Sep 01 2021 dimstar@opensuse.org
- Update to version 0.104+15:
  * [upstream] track some more gnome packages
* Fri May 14 2021 dimstar@opensuse.org
- Update to version 0.104+14:
  * obs-db/upstream: range expects an int value
  * No longer try to download GNOME 3.12 data - EOL
  * Upstream: track gnome-tour (new in GNOME 40)
* Tue Feb 09 2021 dimstar@opensuse.org
- Update to version 0.104+11:
  * osc-collab: Do not crash if we encounter a (broken) package (version unknown)
  * gnome-versions: fix crash in new GNOME version scheme code
* Fri Jan 15 2021 dimstar@opensuse.org
- Update to version 0.104+9:
  * upstream: Follow GNOME's new versioning scheme
  * client: fix crash in case the parent version could not be identified
* Fri Jan 15 2021 dimstar@opensuse.org
- Update to version 0.104+7:
  * gnome-version: use rpm.labelCompare to compare version numbers
  * gnome-versions: ignore ../ directory
* Fri Jan 15 2021 dimstar@opensuse.org
- Update to version 0.104+5:
  * gnome-versions: fix extraction of versions with new gdo UI
* Fri Jan 15 2021 dimstar@opensuse.org
- Update to version 0.104+4:
  * gnome-versions: sync up with latest download.gnome.org UI
* Mon Jul 13 2020 dimstar@opensuse.org
- Update to version 0.104+3:
  * gnome-updates: upstream no longer tracks a -stable.config
  * gnome-versions: fix typo
* Mon Feb 24 2020 dimstar@opensuse.org
- Update to version 0.104+1:
  * Cleanup TMPDIR at the end of collecting GNOME versions
* Wed Feb 12 2020 dimstar@opensuse.org
- Update to version 0.104:
  * upstream-packages-match.txt: GTK+ was renamed to GTK
* Wed Feb 12 2020 dimstar@opensuse.org
- Update to version 0.103+13:
  * run-upstream: remove debug print
  * No longer track legacy openSUSE releases < Leap 15.2
  * Track GNOME:STABLE:3.34
  * Add main runner
  * Prepare for better pkg installation
  * run-gnome-versions: adjust cache path in line with the rest of the tool
  * run-updategit: not needed: this is now properly packaged
  * Add gnome-upstream version tooling
  * Convert upstream scripts to python3
  * buildservice: use osc to download stuff
  * Auto-convert obs-db to python3 by 2to3
  * Update default configuration for openSUSE installation (based on package)
* Mon Feb 10 2020 dimstar@opensuse.org
- Switch to use _source service:
  + We need the entire git tree, as newly we also produce server
    packages. This is possibly less interesting for the masses, but
    the openSUSE infrastructure will use this package.