Package Release Info

netcdf_4_6_1-gnu-openmpi2-hpc-4.6.1-bp151.5.9.2

Update Info: openSUSE-2021-120
Available in Package Hub : 15 SP1 Update

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

libnetcdf-gnu-openmpi2-hpc
libnetcdf_4_6_1-gnu-openmpi2-hpc
netcdf-gnu-openmpi2-hpc
netcdf-gnu-openmpi2-hpc-devel
netcdf_4_6_1-gnu-openmpi2-hpc
netcdf_4_6_1-gnu-openmpi2-hpc-devel
netcdf_4_6_1-gnu-openmpi2-hpc-devel-static

Change Logs

Version: 4.6.1-bp150.3.1
* Tue May 08 2018 adrian@suse.de
- go back to hdf5 1.10
* Mon Apr 30 2018 eich@suse.com
- Fix devel-data package conflicts by a Provides/Conflicts that
  doesn't collide with a package name.
* Mon Apr 30 2018 eich@suse.com
- Remove the 'ring magic' as this seems to create issues during
  verification.
* Mon Apr 30 2018 eich@suse.com
- (Temporarily) disable fpr S390* as a check test fails currently
  on BE.
* Mon Apr 30 2018 eich@suse.com
- Fix dependency issues with non-HPC devel packages and
  devel-data.
* Mon Apr 30 2018 eich@suse.com
- Add a dependency to the HPC master package of the correct
  flavor of libhdf5_hl (bsc#1091243).
* Tue Apr 24 2018 jberry@suse.com
- Avoid file conflict between devel-data packages over rpm macros.
* Wed Apr 11 2018 eich@suse.com
- Disable non-HPC builds on non-openSUSE systems:
  a. currently only SUSE products/projects are supported/
  b. non-HPC builds are not and have never been supported on SLE,
    on openSUSE they are provided for compatibility reasons.
* Wed Apr 04 2018 adrian@suse.de
- update to version 4.6.1 (FATE#325561)
  * changes since 4.4.4.1 are documented here:
    https://www.unidata.ucar.edu/blogs/news/entry/netcdf-4-6-1
    https://www.unidata.ucar.edu/blogs/news/entry/netcdf-4-6-0
    https://www.unidata.ucar.edu/blogs/news/entry/netcdf-4-5-0
- Obsoletes all patches:
  netcdf-disable-szip-linking.patch
  netcdf-h5-test-fix-type-mismatch.patch
  netcdf-no_date_time.patch
- drop hdf4 support
- use version 1.8 of hdf5 in non-hpc mode to avoid incompatible
  on-disk data
* Fri Feb 09 2018 eich@suse.com
- Add support for openmpi2 for HPC (FATE#325089).
* Fri Feb 09 2018 cgoll@suse.com
- Fix summary in module files (bnc#1080259)
* Fri Jan 19 2018 eich@suse.com
- Change the name of the MPI version of the module file directory
  to pnetcdf to distinguish it from the 'serial' one (boo#1075933).
* Fri Jan 12 2018 eich@suse.com
- Disable the openmpi3 flavor in some products.
* Fri Jan 05 2018 eich@suse.com
- Switch from gcc6 to gcc7 as additional compiler flavor for HPC on SLES.
- Add support for mpich and openmpi3 for HPC.
* Fri Nov 10 2017 eich@suse.com
- Add dependency on the hpdf5 library package
  to the netdf libary package.
* Thu Nov 02 2017 eich@suse.com
- Simplify Group: - do not destinguish between MPI
  and non-MPI: the IBS check scripts cannot handle
  this well.
* Mon Oct 30 2017 eich@suse.com
- Fix wrong Requires: in static package.
* Sat Oct 28 2017 eich@suse.com
- Add minimal mpi-selector support for non-HPC MPI build.
  This will avoid the MPI packages to conflict with the
  'serial' ones as both provide the same files and libs.
* Sat Oct 28 2017 eich@suse.com
- Add minimal mpi-selector support for non-HPC MPI build.
  This will avoid the MPI packages to conflict with the
  'serial' ones as both provide the same files and libs.
* Tue Oct 24 2017 jjolly@suse.com
- Added patch netcdf-h5-test-fix-type-mismatch.patch
  * Fixes type mismatch in test tst_h_dimscales
    (bsc#1064705).
Version: 4.6.1-bp151.4.4
* Wed Feb 13 2019 Egbert Eich <eich@suse.com>
- Consolidate use of openmpi1, openmpi2, openmpi3.
* Mon Jan 07 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
- Add support for openmpi2 flavor
  * own directories below _mandir for all MPI flavors
  * no support for parallel_netcdf yet, same as for HPC flavors
- Enable valgrind support also for aarch64
- defattr, license spec file cleanup
* Wed Nov 14 2018 Stefan Brüns <stefan.bruens@rwth-aachen.de>
- Only create a single devel-data subpackage providing the identical
  macros.netcdf, and require it by both serial and openmpi devel packages.
Version: 4.6.1-bp151.5.3.1
* Mon Jul 20 2020 Egbert Eich <eich@suse.com>
- Remove requirements for parallel-netcdf from non-HPC builds:
  without the '--enable-pnetcdf' configure option, this doesn't
  make sense.
* Mon Jul 20 2020 Egbert Eich <eich@suse.com>
- Remove build restrictions for SLE builds: build all flavors for
  SLE.
- Fix ldconfig args for HPC packages: no caching should be done
  as these libs are made available thru LD_LIBRARY_PATH tweaking.
- Adhere to common conventions regarding NetCDF and PnetCDF:
  NetCDF modules should be called 'netcdf' - regardless whether
  they are 'serial' or use MPI (boo#1174291).