Package Release Info

libolecf-20210512-bp154.3.20

Update Info: Base Release
Available in Package Hub : 15 SP4

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

libolecf-debuginfo
libolecf-debugsource
libolecf-devel
libolecf-tools
libolecf-tools-debuginfo
libolecf1
libolecf1-debuginfo
python3-libolecf
python3-libolecf-debuginfo

Change Logs

* Mon Jan 24 2022 Jan Engelhardt <jengelh@inai.de>
- Enable multipython builds. (This reenables python2 on Leap 15.)
* Sun Nov 14 2021 Jan Engelhardt <jengelh@inai.de>
- Switch to curated tarballs
* Sat Jun 26 2021 Jan Engelhardt <jengelh@inai.de>
- Drop python2 module build.
* Thu May 13 2021 Jan Engelhardt <jengelh@inai.de>
- Update to snapshot 20210512 (381cbe88)
  * No changelog was provided
- Add system-libs.patch
* Wed Dec 30 2020 Greg Freemyer <Greg.Freemyer@gmail.com>
- update to 20201004
  * worked on python bindings
- remove BuildRequires:  pkg-config
- add COPYING* to the %license line
* Tue May 05 2020 Dominique Leuenberger <dimstar@opensuse.org>
- Allow distros to disable python2 builds (bcond_withou python2):
  Tumbleweed already declares this, as python2 is EOL.
* Wed Apr 15 2020 Greg Freemyer <Greg.Freemyer@gmail.com>
- quit using libfdatetime and libfvalue from factory
  * using the factory version causes python-plaso self-test to fail
* Wed Apr 08 2020 Greg Freemyer <Greg.Freemyer@gmail.com>
- update to 20191221
  * changes for libcdata
  * Worked on mount tool
- rename python-libolecf to python2-libolecf
- add python3-libolecf subproject
- use libfdatetime, libfvalue, libcerror, libcsystem from factory instead of internal version
* Mon Apr 01 2019 Greg Freemyer <Greg.Freemyer@gmail.com>
- update to 20181231
  * Worked on python bindings
  * Changes for get item by path.
  * Worked on olecfinfo
  * changes for libcdata
  * Changes to file name sanitation in export handle
  * removed libcsystem dependency
- removed libcsystem dependency
* Wed Jul 13 2016 Greg.Freemyer@gmail.com
- update to 20160109
  * fixes for rpmbuild
Version: 0~20160107-bp150.2.4
* Tue Jan 26 2016 Greg.Freemyer@gmail.com
- update to v0~20160107
  * worked on Python 3 support
  * 2016 update
- use libcdata from factory, not internal.  Tested via plaso/run_tests.py
- use libcerror internal package.  Build fails with factory version
- use libcstring internal package.  Build fails with factory version
- use libfvalue internal package.  Build fails with factory version
* Sat Jan 23 2016 Greg.Freemyer@gmail.com
- update to v0~20151223
  * worked on format support
  * applied updates
  * worked on Python bindings
  * changed version for pypi repacking
  * worked on setup.py
  * bug fixes after fuzzing with AFL
  * improved support file without directory entries
  * added more bounds checks
- required by plaso v1.4
- update BuildRequires libfvalue to require version 0~20151226
* Wed Jan 14 2015 Greg.Freemyer@gmail.com
- update to v0~20150106
  * 2015 update
  * worked on Python 3 support
  * worked on tests
  * code clean up
  * bug fix in Python-bindings
  * update Python-bindings tests
  * worked on libfwps support
- update URL to the new github site
- replace Source: field with fully defined URL
- remove DL-URL comment
- start using new libyal packages from OBS, not internal version
- remove %if opensuse logic.  Not needed with libyal in security:forensics
* Thu Aug 28 2014 Greg.Freemyer@gmail.com
- use libfdatetime internal package.  With external factory version fails testing.
- use libcdata internal package.  With external factory version fails testing.
* Wed Aug 20 2014 Greg.Freemyer@gmail.com
- add "Requires:  %lname = %version" to tools sub-project
- add "Provice:  pyolecf" to match upstream requires
* Wed Aug 13 2014 Greg.Freemyer@gmail.com
- updated to 0~20140801
  * worked on Python bindings
  * bug fix in Python-bindings
  * worked on olecfmount Dokan support
  * updated dependencies
  * small changes to Makefile
  * worked on setup.py
  * 2014 update
- use external package for libfguid
* Sat Nov 23 2013 Greg.Freemyer@gmail.com
- updated to 20131108
  * added support for 0 value sub directory entry not being used as index.
* Wed Oct 16 2013 Greg.Freemyer@gmail.com
- add %if logic around BuildRequires to allow use of internal packages on older distros
* Wed Oct 16 2013 Greg.Freemyer@gmail.com
- initial package (v0~20131012)