Package Release Info

libkolabxml-1.1.6-bp153.1.132

Update Info: Base Release
Available in Package Hub : 15 SP3

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

java-libkolabxml1
libkolabxml-devel
libkolabxml1

Change Logs

Version: 1.1.2-2.1
* Fri Jan 08 2016 tittiatcoke@gmail.com
- New upstream release 1.1.2
  - Build fixes for the tests (Qt5 related)
* Fri Aug 07 2015 tittiatcoke@gmail.com
- New upstream release 1.1.1
  - Qt5 support for the tests
* Mon Apr 06 2015 aj@ajaissle.de
- Add %bcond_with tests
- libqt4-devel is only needed for the tests
- Add %check section; only run %check when %{with tests} in on
- Set minversion for some of the build requirements
* Wed Apr 01 2015 aj@ajaissle.de
- New upstream release 1.1.0
- Drop patch (upstream inclusion):
  - libkolabxml-1.0.3_make_version_attribute_not_a_fixed_value.patch
* Sat Mar 28 2015 aj@ajaissle.de
- Add libkolabxml-1.0.3_make_version_attribute_not_a_fixed_value.patch:
  Instead of a fixed value, we only use a default value.
  Fixes problems where objects created with version string '3.0dev'
  can not be fetched/displayed.
- Convert %with_java to %bcond_without java
* Mon Mar 23 2015 schwab@suse.de
- Allow building without mono bindings
* Wed Dec 10 2014 aj@ajaissle.de
- Reenable building for non-Factory openSUSE
* Sat Nov 08 2014 hrvoje.senjan@gmail.com
- Revert the added Requires in devel subpackage from previous change:
  if someone needs bindings explicitly, they can buildrequire them
  explicitly
* Fri Nov 07 2014 tchvatal@suse.com
- Version bump to 1.0.3
- Cleanup with spec-cleaner
- no-undefined disabled as php-bindings cant cope with it
* Tue Aug 26 2014 aj@ajaissle.de
- New upstream release 1.0.2
- Dropped the following patches, as they're now included upstream:
  - libkolabxml-1.0.1_xsd_type.patch
  - libkolabxml-1.0.1_csharp_bindings.patch
* Mon Aug 04 2014 aj@ajaissle.de
- Added patch libkolabxml-1.0.1_xsd_type.patch
  - Fix compatibility with xsd 4.0.0
* Mon Nov 25 2013 aj@ajaissle.de
- libkolabxml-1.0.1_no-maybe-uninitialized.patch
  * Remove no-maybe-unititialized cxx flag from SLE builds (not supported)
- Renamed csharp_bindings.diff to libkolabxml-1.0.1_csharp_bindings.patch
- Renamed fix_uuid_includes_SLE.diff to libkolabxml-0.8.3_fix_uuid_includes_SLE.patch
* Thu Nov 21 2013 aj@ajaissle.de
- New upstream release 1.0.1
- soname changed from 0 to 1
* Wed Nov 20 2013 aj@ajaissle.de
- New upstream release 0.8.5
- csharp_bindings.diff: Fix csharp bindings
* Wed Nov 13 2013 aj@ajaissle.de
- Bindings require libkolabxml
* Sun Sep 15 2013 hrvoje.senjan@gmail.com
- Fix build for Factory - make java subpackage owns %_libdir/java
  directory
* Wed Jun 19 2013 schwab@suse.de
- Make mono bindings optional
* Sat Jun 08 2013 aj@ajaissle.de
- Cleaning up spec file to reduce prjconf settings
* Mon Apr 29 2013 aj@ajaissle.de
- Removed fix_php5_bindings.diff
* Wed Apr 24 2013 aj@ajaissle.de
- New upstream version 0.8.4
  * Fixes an issue in the bindings generated (related to event vectors)
- Disabled fix_php5_bindings.diff (fixed in 0.8.4)
Version: 1.1.6-bp150.2.6
* Tue Oct 03 2017 fstrba@suse.com
- Don't require gcc-java for the java bindings, since gcc-java will
  be removed
* Thu Aug 17 2017 tchvatal@suse.com
- Drop patches to build against sle11:
  * libkolabxml-0.8.3_fix_uuid_includes_SLE.patch
  * libkolabxml-1.0.1_no-maybe-uninitialized.patch
- Remove few sle11/old openSUSE conditions to make it more readable
- Disable php on TW as php7 is not supported by the code and php5
  is removed
* Mon Feb 13 2017 jengelh@inai.de
- RPM group fix; drop unnecessary use of %__ type macros
* Sat Feb 11 2017 lbeltrame@kde.org
- Add libboost_Date_time-devel and libboost_chrono-devel to
  requirements to make them explicit (implicitly required by
  libboost_thread)
* Wed Feb 08 2017 wbauer@tmo.at
- Add missing libboost-*-devel requirements to the devel package
  to fix the build of dependent packages in Tumbleweed
* Wed Feb 01 2017 adam.majer@suse.de
- use individual libboost-*-devel packages instead of boost-devel
* Wed Nov 23 2016 wbauer@tmo.at
- disable parallel build to hopefully fix random build failures
* Wed Nov 16 2016 aj@ajaissle.de
- New upstream release 1.1.6
  + The created date is optional
- New upstream release 1.1.5
  + Support audio alarms without an attachment
- New upstream release 1.1.4
  + The tests require valid created dates
- New upstream release 1.1.3
  + The "created" property must be a UTC date-time
* Fri Jul 22 2016 wbauer@tmo.at
- Remove kdelibs4support-devel from the build requirements, it's
  not needed
Version: 1.1.6-bp152.6.12
* Thu May 14 2020 Fabian Vogt <fabian@ritter-vogt.de>
- Disable mono bindings by default, broken with latest mono changes
  in TW and not used by anything currently
* Thu May 14 2020 Christophe Giboudeaux <christophe@krop.fr>
- Remove more obsolete conditions.
* Tue Jan 14 2020 Christophe Giboudeaux <christophe@krop.fr>
- Drop the python bindings package to get rid of the python2 dependency.
- Remove obsolete conditions.
* Tue Sep 17 2019 Christophe Giboudeaux <christophe@krop.fr>
- add 0001-Make-sure-boost-is-found-when-using-libkolabxml.patch.
  boost is a public dependency and must be searched before using libkolabxml.
* Thu Apr 11 2019 Christophe Giboudeaux <christophe@krop.fr>
- Make sure libxerces-c-devel is installed before using
  libkolabxml-devel.