Package Release Info

libKF5NetworkManagerQt-5.20.0-3.1

Update Info: openSUSE-2016-739
Available in Package Hub : 12 SP1-SP5

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

libKF5NetworkManagerQt-devel
libKF5NetworkManagerQt6

Change Logs

* Sun Mar 06 2016 hrvoje.senjan@gmail.com
- Update to 5.20.0 (boo#970856)
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.20.0.php
* Sat Feb 06 2016 hrvoje.senjan@gmail.com
- Update to 5.19.0 (boo#967668)
  * Re-check connection state and other properties to be sure
    they are actual (version 2) (kde#352326)
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.19.0.php
* Sat Jan 02 2016 hrvoje.senjan@gmail.com
- Update to 5.18.0
  * Make it work with older NM versions
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.18.0.php
- Drop upstreamed 0001-make-it-work-with-older-NM-versions.patch
* Wed Dec 16 2015 alarrosa@suse.com
- Added 0001-make-it-work-with-older-NM-versions.patch committed also
  upstream. This adds some #ifdefs around code that needs NM 0.9.10
  so it also builds with NM 0.9.8
* Thu Dec 10 2015 hrvoje.senjan@gmail.com
- Update to 5.17.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.17.0.php
* Sun Nov 08 2015 hrvoje.senjan@gmail.com
- Update to 5.16.0 (boo#955067)
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.16.0.php
* Mon Oct 05 2015 hrvoje.senjan@gmail.com
- Update to 5.15.0
  * Fix introspections, LastSeen should be in AccessPoint and
    not in ActiveConnection
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.15.0.php
* Tue Sep 08 2015 hrvoje.senjan@gmail.com
- Update to 5.14.0
  * Added new properties from the latest NM snapshot/releases
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.14.0.php
* Tue Aug 04 2015 hrvoje.senjan@gmail.com
- Update to 5.13.0
  * The Qt version requirement has been bumped from 5.2 to 5.3
  * Debug output has been ported to categorized output, for less
    noise by default
  * Docbook documentation has been reviewed and updated
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.13.0.php
* Sun Jul 05 2015 hrvoje.senjan@gmail.com
- Update to 5.12.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.12.0.php
* Sun Jun 07 2015 hrvoje.senjan@gmail.com
- Update to 5.11.0
  * Drop WiMAX support for NM 1.2.0+
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.11.0.php
* Sun May 03 2015 hrvoje.senjan@gmail.com
- Update to 5.10.0
  * The installed headers are now organized like all other frameworks
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.10.0.php
* Sat Apr 04 2015 hrvoje.senjan@gmail.com
- Update to 5.9.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.9.0.php
- NetworkManager is a public dep, so add the correct requires to
  devel package (pkgconfig(NetworkManager), pkgconfig(libnm-glib)
  and pkgconfig(libnm-util))
* Sat Mar 07 2015 hrvoje.senjan@gmail.com
- Update to 5.8.0
  * Add new properties and methods from NetworkManager 1.0.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.8.0.php
* Sun Feb 08 2015 hrvoje.senjan@gmail.com
- Update to 5.7.0
  * Do not print a message about unhandled "AccessPoints" property
  * Added support for NetworkManager 1.0.0 (not required)
  * Fixed VpnSetting secrets handling
  * Added class GenericSetting for connections not managed by
    NetworkManager
  * Added property AutoconnectPriority to ConnectionSettings
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.7.0.php
- Drop vpn.patch, merged upstream
* Tue Jan 13 2015 hrvoje.senjan@gmail.com
- Added vpn.patch from upstream
* Sat Jan 03 2015 hrvoje.senjan@gmail.com
- Libary is now officially a part of KDE Frameworks 5 libraries
- Update to 5.6.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.6.0.php
- Update summary and descriptions
- Be more explicit about BuildRequires (using pkgconfig, etc)
- Added baselibs.conf
* Thu Dec 11 2014 hrvoje.senjan@gmail.com
- Update to 5.1.2:
  * Bugfix release
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.1.2.php
* Thu Nov 06 2014 hrvoje.senjan@gmail.com
- Update to 5.1.1:
  * Bugfix release
  * Do not notify about changed VpnState twice
  * Watch for changes when constructing new ModemDevice
  * Add workaround to properly update IpInterface
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.1.1.php
* Thu Oct 09 2014 hrvoje.senjan@gmail.com
- Update to 5.1 Final:
  * Bugfixes since RC1
  * For more details please see:
    https://www.kde.org/announcements/plasma-5.1.0.php