Package Release Info

kdebase4-workspace-4.11.22-bp152.4.14

Update Info: Base Release
Available in Package Hub : 15 SP2

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

kde4-kgreeter-plugins
kdebase4-workspace
kdebase4-workspace-addons
kdebase4-workspace-devel
kdebase4-workspace-liboxygenstyle
kdebase4-workspace-liboxygenstyle-64bit
kdebase4-workspace-libs
kdebase4-workspace-libs-64bit
kdm
kdm-branding-upstream
krandr
kwin
oxygen4-cursors

Change Logs

* Wed Dec 04 2019 Ludwig Nussel <lnussel@suse.de>
- require pkgconfig(xdamage) for building (boo#1158387)
Version: 4.11.22-bp150.1.3
* Tue Feb 27 2018 dimstar@opensuse.org
- Use SPDX3.0 license tags and package COPYING as %license.
* Tue Feb 27 2018 fabian@ritter-vogt.de
- Add explicit BuildReq: pkgconfig(xkbcommon-x11), (xkbfile),
  (xcomposite), (xdmcp) and (xft)
* Wed Jan 03 2018 fabian@ritter-vogt.de
- Remove Requires: polkit-kde-agent-1 as it got dropped
* Mon Dec 11 2017 tittiatcoke@gmail.com
- Drop the build of python-kdebase4 as that python-kde4 is no
  longer available
* Sat Dec 02 2017 fabian@ritter-vogt.de
- Add patch to not build against Qt4 WebKit:
  * skip-qtwebkit-parts.patch
  * Drop ksysguard, not built anymore
  * Adjust filelist
* Thu Nov 23 2017 rbrown@suse.com
- Replace references to /var/adm/fillup-templates with new
  %_fillupdir macro (boo#1069468)
* Wed Oct 18 2017 wbauer@tmo.at
- Have update-alternatives handle Xinit's integration of the
  displaymanager, replacing /etc/sysconfig/displaymanager
  (boo#1053863)
* Wed Aug 30 2017 fabian@ritter-vogt.de
- Don't BuildRequire qalculate to fix building
  (no point in fixing)
* Wed May 17 2017 fabian@ritter-vogt.de
- Update gcc7-fix.diff to fix another error reported by GCC7
* Mon Apr 03 2017 wbauer@tmo.at
- Add gcc7-fix.diff to fix an error reported by GCC7 (boo#1031317)
* Wed May 25 2016 wbauer@tmo.at
- Changed kdm-sysconfig-values.diff:
  Add "-listen tcp" to the Xserver cmdline for Xorg 1.17 and up if
  DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="yes" in
  /etc/syconfig/displaymanager, newer versions have -nolisten as
  default (boo#978262)
* Tue May 24 2016 martin.liska@suse.com
- Add patch  gcc6-fixes.diff to fix errors reported by GCC6 compiler
* Wed Jan 20 2016 tittiatcoke@gmail.com
- Drop the upstream branding package for workspace. This is no
  longer required. Move the files from the upstream branding
  package to the workspace package.
* Sun Dec 06 2015 p.drouand@gmail.com
- Replace libusb-devel with pkgconfig(libusb-1.0); ensure
  kdebase4-workspace build against libusb-1.0
* Tue Nov 10 2015 wbauer@tmo.at
- Apply systemsettings-desktop-kde4.diff (instead of
  systemsettings-desktop.diff) on Leap too (boo#954252)
* Sun Oct 11 2015 hrvoje.senjan@gmail.com
- Require kscreen only on older releases
- Devel subpackage doesn't need main subpackage
* Wed Oct 07 2015 alarrosa@suse.com
- Changed usage of %{is_opensuse} to work when not defined
* Wed Sep 02 2015 alarrosa@suse.com
- When in SLE12, require desktop-data-SLE instead of desktop-data-openSUSE
* Tue Sep 01 2015 alarrosa@suse.com
- SLE12 doesn't provide waylang-egl so don't require it
* Mon Aug 24 2015 tittiatcoke@gmail.com
- Update to 4.11.22
  * KDE Applications 15.08.0
  * https://www.kde.org/announcements/announce-applications-15.08.0.php
- Drop upstreamed patch kdm-fix-input-focus.patch
Version: 4.11.22-bp151.4.2
* Tue Mar 26 2019 Christophe Giboudeaux <christophe@krop.fr>
- Remove the last %kde4_pimlibs_requires line.
  Nothing should require kdepimlibs4 anymore.
* Tue Nov 27 2018 Luca Beltrame <lbeltrame@kde.org>
- Remove gpsd-devel BuildRequires, not only it breaks with latest
  gpsd, but it is also completely unused (Plasma 4.x is no longer
  present in any supported openSUSE version)