Package Release Info

julia-compat-1.0.3-bp153.3.75

Update Info: Base Release
Available in Package Hub : 15 SP3

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

julia-compat
julia-compat-debug
julia-compat-devel

Change Logs

Version: 0.6.2-bp150.1.6
* Thu Apr 19 2018 guillaume.gardet@opensuse.org
- Pass right MARCH value for ppc64le
- Build only for supported architectures
- Fix armv6 build by passing atomic lib to linker
* Tue Mar 27 2018 guillaume.gardet@opensuse.org
- Pass right march option for %arm and aarch64
* Wed Dec 20 2017 ronisbr@gmail.com
- Remove patch `julia-0.6.1-dont-rebuild-docs-on-install.patch`,
  since the issue was already fixed by upstream.
- Version bump to 0.6.2.
  * Bugfix release, no changelog available.
- Update license information according to file `LICENSE.md`.
* Wed Nov 01 2017 ronisbr@gmail.com
- Run spec-cleaner.
- Version bump to 0.6.1.
  * Bugfix release, no changelog available.
- Add patches:
  * `julia-0.6.1-dont-rebuild-docs-on-install.patch`
    This patch avoids documentation rebuilding in `make
    install` command. For more information, see:
    https://github.com/JuliaLang/julia/issues/24432
  * `julia-env-script-interpreter.patch`
    This patch removes a RPMLINT error.
* Sat Aug 19 2017 ronisbr@gmail.com
- Add script to get the right libgit2 version. Hence, it will not
  be necessary anymore to update the .spec every time libgit2 is
  updated.
* Fri Aug 18 2017 ronisbr@gmail.com
- Update runtime dependency: `libgit2-25` -> `libgit2-26`.
* Mon Jul 03 2017 ronisbr@gmail.com
- Version bump to 0.6.0, see NEWS.md for details.
- Remove unneeded patch `julia-disable-llvm-timestamps.patch`.
* Fri Mar 24 2017 ronisbr@gmail.com
- Update runtime dependency: `libgit2-24` -> `libgit2-25`.
  * Fixes boo#1030824.
* Wed Mar 08 2017 ronisbr@gmail.com
- Version bump to 0.5.1.
  * Bugfix release, no changelog available.
- Update patch `julia-disable-llvm-timestamps.patch`.
* Mon Oct 31 2016 ronisbr@gmail.com
- Add `libdSFMT2_2` as runtime dependency, since rpm is not
  automatically adding it.
* Tue Sep 20 2016 ronisbr@gmail.com
- Version bump to 0.5.0, see NEWS.md for details.
* Tue Sep 13 2016 ronisbr@gmail.com
- Version bump to 0.5.0~rc4.
  * The changelog will be available when the version 0.5.0 is
    released.
- Julia is now built using `libopenblas_openmp0` as the lapack and
  blas libraries due to upstream advice. For more information, see:
    https://github.com/JuliaLang/julia/issues/18394
- Remove white spaces in .changes files.
* Tue Aug 30 2016 ronisbr@gmail.com
- Fix `julia-debug` dependency.
- Move `libccalltest.so.debug` to `julia-debug` package
* Thu Aug 25 2016 ronisbr@gmail.com
- Version bump to 0.5.0~rc3;
  * The changelog will be available when the version 0.5.0 is
    released.
- Remove unnecessary build options `USE_SYSTEM_MBEDTLS=1` and
  `USE_SYSTEM_LIBSSH2=1`, because we are using the system libgit2
  to build julia. For more information, see:
    https://github.com/JuliaLang/julia/issues/17884
* Mon Aug 22 2016 ronisbr@gmail.com
- Add `libgit2` as a runtime dependency.
* Fri Aug 12 2016 ronisbr@gmail.com
- Version bump to 0.5.0~rc2.
  * The changelog will be available when the version 0.5.0 is
    released.
* Thu Aug 11 2016 ronisbr@gmail.com
- Version bump to 0.5.0~rc1.
  * The changelog will be available when the version 0.5.0 is
    released.
- Add package `julia-debug`, which contains a debugging version of
  Julia system image and Julia library.
* Thu Aug 04 2016 ronisbr@gmail.com
- User oertel (ro@suse.com) fix the `_constraints` file because the
  sse flags only exists in x86 architectures. See Request 416497.
* Wed Jun 22 2016 ronisbr@gmail.com
- Version bump to 0.4.6.
  * Bugfix release, no changelog available.
- Re-enable i586 architecture.
  * After the full rebuild caused by gcc6, julia started to
    correctly build against i586 again. The root cause of the
    problem was not identified yet.
* Fri Apr 29 2016 ronisbr@gmail.com
- Due to a bug, it is not possible now to build julia against i586
  with glibc 2.23. The root of the problem has not been determined
  yet. Two bugs were filled in upstream:
    _ https://github.com/JuliaLang/julia/issues/16087
    _ https://llvm.org/bugs/show_bug.cgi?id=27548
  Thus, the support for julia in i586 architectures is being
  dropped until this bug is fixed.
Version: 1.0.3-bp151.3.2
* Sun Dec 16 2018 ronisbr@gmail.com
- Version bump to 1.0.3.
  * Bugfix release, no changelog available.
* Mon Nov 05 2018 Ronan Chagas <ronisbr@gmail.com>
- Version bump to 1.0.1.
  * Bugfix release, no changelog available.
* Mon Sep 24 2018 Ronan Chagas <ronisbr@gmail.com>
- Version bump to 1.0.0.
  * v1.0.0 is basically v0.7.0 without deprecation warnings.
* Wed Aug 08 2018 ronisbr@gmail.com
- Version bump to 0.7.0, see NEWS.md for details.
- Add new required bundled dependency by the new v0.7.0.
  * libwhich: 81e9723c0273d78493dc8c8ed570f68d9ce7e89e
- Bump bundled dependencies as required by the new v0.7.0.
  * libuv: ed3700c849289ed01fe04273a7bf865340b2bd7e
  * llvm: 6.0.0
- Update patch `julia-env-script-interpreter.patch`.
- Remove unnecessary bundled dependency:
  * Rmath: julia-0.1
- Remove empty package `julia-examples`.
* Sun Jul 22 2018 ronisbr@gmail.com
- Version bump to 0.6.4.
  * Bugfix release, no changelog available.
* Fri Jun 01 2018 ronisbr@gmail.com
- Version bump to 0.6.3.
  * Bugfix release, no changelog available.
- Bump utf8proc version as required by the new v0.6.3.
- Change LICENSE.md from %doc to %license.
Version: 1.0.3-bp152.4.25
* Mon Mar 09 2020 Ronan Chagas <ronisbr@gmail.com>
- Remove constraints of CPU flag since it was blocking the builds.