Package Release Info

hypre-mpich-2.20.0-bp154.1.39

Update Info: Base Release
Available in Package Hub : 15 SP4

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

hypre-mpich-debugsource
hypre-mpich-devel
libHYPRE2_20_0-mpich
libHYPRE2_20_0-mpich-64bit
libHYPRE2_20_0-mpich-64bit-debuginfo
libHYPRE2_20_0-mpich-debuginfo

Change Logs

Version: 2.15.1-bp151.1.1
* Wed Feb 27 2019 Egbert Eich <eich@suse.com>
- Build the examples and docs as a separate HPC package.
- Made example and doc packages 'noarch'.
- Remove duplicates from examples.
- Fix rpmlint warnings about macros in comments.
- Fix library path to work both on 32 and 64 bit.
* Tue Feb 26 2019 cgoll@suse.com
- Switched to cmake build system to fix boo#1126367
  * added hypre_CMakeLists.patch for proper version numbering
  * added dependency for lapack and superlu devel for non hpc builds
- Due to boo#1127070 does not compile for mvapich2/mpich
* Wed Feb 13 2019 Antoine Ginies <aginies@suse.com>
- Add a sub examples package to test in prod env
  Add: hypre_Makefile_examples.patch
* Sun Feb 10 2019 Egbert Eich <eich@suse.com>
- Properly create and tear down default version links when the
  HPC master packages are installed/uninstalled.
- Fix dependencies for HPC.
- Add dependency to HPC modulefile.
- Fix package groups.
- Add pkgconfig file.
- Consolidate use of openmpi1, openmpi2, openmpi3 for non-HPC builds.
* Fri Jan 25 2019 eich@suse.com
- Disable openmpi1 builds on SLE.
* Mon Jan 14 2019 eich@suse.com
- Fix yet another library dependency.
* Mon Jan 14 2019 eich@suse.com
- Fix HPC libname for master package.
* Sun Jan 13 2019 eich@suse.com
- Disable openmpi3 builds on SLE.
* Sat Jan 12 2019 Jan Engelhardt <jengelh@inai.de>
- Trim future goals, trim filler wording.
* Mon Jan 07 2019 eich@suse.com
- Add more MPI flavors.
- Create baselib.conf on the fly.
- Do not build non-HPC on SLE to save build cycles.
- Remove babel_files: not used anywhere.
- Remove unneeded BuildRequires:.
* Mon Jan 07 2019 cgoll@suse.com
- Added HPC support.
* Sun Jan 06 2019 Stefan BrĂ¼ns <stefan.bruens@rwth-aachen.de>
- Update to 2.15.1
- Drop hypre-2.8.0b-no-date-and-time-fix.patch
- Convert to multibuild for openmpi/openmpi2
* Thu Aug 02 2012 scorot@free.fr
- add baselibs.conf
- build serial version
- fix shared libs package name
* Thu Aug 02 2012 scorot@free.fr
- patch0
- move %%doc files to devel package
* Mon Jul 30 2012 scorot@free.fr
- add mvapich2 build for SLE 11
* Sun Jul 29 2012 scorot@free.fr
- fist package based on alt linux spec file
Version: 2.18.2-bp152.1.1
* Tue May 05 2020 Egbert Eich <eich@suse.com>
- Add non-HPC openmpi3 flavor.
* Fri Apr 17 2020 Egbert Eich <eich@suse.com>
- Enable non-HPC openmpi3 build (boo#1169792).
- Remove bogus %undefine suffix - suffix is a RPM builtin, and
  trying to undefine it is an error since RPM 4.15.
* Fri Nov 29 2019 Egbert Eich <eich@suse.com>
- Add support for gcc7.
- Add support for gcc8 and gcc9 (jsc#SLE-7766 & jsc#SLE-8604).
* Thu Nov 28 2019 Egbert Eich <eich@suse.com>
- Update to 2.18.2:
  * Fixed mixedint bugs.
  * Ported BoomerAMG setup to run on GPUs.  Only a subset of setup phase
    features are currently available.
  * Updated CMake to support more of the features available in configure/make.
  * Added RecomputeResidual options to several hybrid solvers.
  * Various bug fixes.
- Disable openmpi1 builds for SLE/Leap > 15.1.
- Adapt build for openmpi1 to reflect naming change on Factory.
- Enable openmpi3 builds for Leap and SLE > 15.1 (jsc#SLE-7773).
- hypre_CMakeLists.patch refreshed and replaced by:
  Fix-library-version-numbering.patch
- Fix-empty-elseif-in-CMakeLists.txt.patch:
  Fix empty elseif() in CMake file.
- Use full package version to identify .so version:
  INSTALL.md states that "The hypre team currently does nothing to ensure
  application binary interface (ABI) compatibility. As a result, all release
  (major, minor, or patch) should be treated as incompatible."
- Replaced -DHYPRE_SEQUENTIAL by -DHYPRE_WITH_MPI
* Mon Sep 02 2019 Ana Guerrero Lopez <aguerrero@suse.com>
- Documentation is only available online now. Remove the -doc package.
* Thu Aug 29 2019 Ana Guerrero Lopez <aguerrero@suse.com>
- New version 2.17.0 (jsc#SLE-8498)
  * Changed open source license to dual MIT/Apache-2.0
  * Removed FEI_mv/ml subdirectory and several FEI header files
  * Various bug fixes.
  * Added new '--enable-mixedint' configure option.
  * Various GPU optimizations
  * Changed documentation to use Sphinx and Doxygen.
- Update License field to reflect the new dual licensing.
- Update source, there is a new GitHub group for hypre.
- Refresh patches:
  * hypre_Makefile_examples.patch
  * hypre_CMakeLists.patch
Version: 2.20.0-bp153.1.14
* Fri Jan 29 2021 Egbert Eich <eich@suse.com>
- Make cmake files installation non-conflicting.
* Fri Jan 29 2021 Egbert Eich <eich@suse.com>
- Fix hypre package conflicts for non HPC packages.
* Thu Jan 28 2021 Egbert Eich <eich@suse.com>
- Change 'Requires:' to other HPC packages to %requires_eq to depend
  on the exact version. This should take care of HPC packages ignoring
  proper ABI versioning.
* Mon Jan 25 2021 Ana Guerrero Lopez <aguerrero@suse.com>
- Update to 2.20.0
  * New matrix-based interpolation routines for AMG (CPU and GPU)
  * Added GPU support for aggressive coarsening in AMG
  * New AMG-DD solver
  * Improved distributed sparse matrix-matrix and triple-matrix product
    performance on GPUs
  * IJMatrix/Vector assembly on GPUs (with pointers to GPU memory)
  * Updated caliper usage
  * Separated C and C++ headers
  * Updated to support superlu-dist version to 6.3.1
  * Moved reference manual API to online documentation
  * New AMG features to keep specified F-points and/or C-points.
  * Added GPU support for AMG setup and several interpolation approaches.
  * New parallel ILU solvers and smoothers.
  * New MGR features.
  * Added several interpolation routines based on matrix-matrix interpolations.
  * Various bug fixes.
- Remove patch merged by upstream
  * Fix-empty-elseif-in-CMakeLists.txt.patch
- Rework patch following upstream changes
  * Fix-library-version-numbering.patch Patch removed
  * Add-library-version.patch Patch added
* Wed Oct 07 2020 Egbert Eich <eich@suse.com>
- Don't include superlu-devel and lapack-devel into HPC devel
  package.
* Fri Sep 11 2020 Egbert Eich <eich@suse.com>
- Add build support for gcc10 to HPC build (bsc#1174439).
- Add openmpi4 flavors.