Package Release Info

gupnp-tools-0.10.2-bp154.1.69

Update Info: Base Release
Available in Package Hub : 15 SP4

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

gupnp-tools
gupnp-tools-debuginfo
gupnp-tools-debugsource
gupnp-tools-lang

Change Logs

* Tue Nov 16 2021 Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 0.10.2:
  + Universal CP: Fix format message error.
  + Bugs fixed: glgo#GNOME/gupnp-tools!20,
    glgo#GNOME/gupnp-tools!21.
  + Updated translations.
* Tue Jun 22 2021 Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 0.10.1:
  + Fix various smaller memory leaks
  + Stop using deprecated functions from GUPnP
  + Update icons
  + Upload: Check that a UDN was provided
  + AV-CP:
  - Some visual improvements like headerbars and symbolic icons
  - Search dialog provides entry completion
  - Add IPv6 support if available
  + Network Light: Add IPv6 support if available
  + Updated translations.
Version: 0.10.0-bp152.1.10
* Sat Jan 25 2020 Dominique Leuenberger <dimstar@opensuse.org>
- No longer recommend -lang: supplements are in use
* Fri Mar 29 2019 Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 0.10.0:
  + Port to GUPnP 1.2.
  + Various Meson fixes.
  + Updated translations.
- Drop gupnp-tools-port-new-gupnp-api.patch: Fixed upstream.
* Sat Jan 05 2019 bjorn.lie@gmail.com
- Update to version 0.8.15:
  + All: Improve desktop files.
  + Build: Port to meson.
  + AV Controlpoint:
  - Fix building against GtkSourceVIew 4.
  - Make it possible to change the UserAgent.
  - Remove g_type_class_add_private.
  - Fix closing the about dialog.
  + Universal Controlpoint: Fix closing the about dialog.
  + Updated translations.
- Drop post(un) handling of desktop_database_post(un), no longer
  needed.
- Switch to meson buildsystem, add meson BuildRequires and macros.
- Replace pkgconfig(gtksourceview-3.0) with
  pkgconfig(gtksourceview-4), pkgconfig(gssdp-1.0) with
  pkgconfig(gssdp-1.2), pkgconfig(gupnp-1.0) with
  pkgconfig(gupnp-1.2) BuildRequires.
- Add pkgconfig(glib-2.0) and pkgconfig(gobject-2.0) BuildRequires:
  align with what meson checks for.
- Drop intltool BuildRequires: No longer needed.
- Add gupnp-tools-port-new-gupnp-api.patch: Fix build with new
  gupnp.
- Add fdupes BuildRequires and macro, remove duplicates.