Package Release Info

goobox-3.6.0-bp154.1.76

Update Info: Base Release
Available in Package Hub : 15 SP4)

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

goobox
goobox-lang

Change Logs

* Mon Sep 20 2021 Stanislav Brabec <sbrabec@suse.com>
- Remove obsolete translation-update-upstream support
  (jsc#SLE-21105).
* Sat Jan 25 2020 Dominique Leuenberger <dimstar@opensuse.org>
- No longer recommend -lang: supplements are in use
* Wed Apr 10 2019 Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 3.6.0:
  + Updated translations.
* Mon Feb 18 2019 bjorn.lie@gmail.com
- Update to version 3.5.2:
  + Updated translations.
* Wed Feb 06 2019 bjorn.lie@gmail.com
- Fix translation-update-upstream call, needed after update of
  translation-update-upstream in distro.
* Mon Jan 07 2019 bjorn.lie@gmail.com
- Update to version 3.5.1:
  + New features and user visible changes:
  - Added a volume button.
  - Moved the toolbar on top.
  - Removed application menu.
  - All dialogs use the headerbar.
  - Removed deprecated functions:
    . GTask instead of GSimpleAsyncResult.
    . G_ADD_PRIVATE instead of g_type_class_add_private.
    . GNotification instead of libnotify.
  - Use meson instead of autotools.
  + Bugs fixed:
  - Fixed crash after ejecting a CD.
  - Automatically load rtl icon variants (bgo#768451).
  - Help: change wording in two sentences (bgo#757730).
  - Added -fPIC -DPIC to CFLAGS (bgo#777448).
  + Updated translations.
- Switch to meson buildsystem, add meson BuildRequires and macros.
* Wed Oct 03 2018 bjorn.lie@gmail.com
- Update to version 3.4.3:
  + Help: change wording in two sentences.
  + Added -fPIC -DPIC to CFLAGS.
  + Updated translations.
- Run spec-cleaner, modernize spec.
- Conditionalize post(un) handling of
  glib2_gsettings_schema_post(un), desktop_database_post(un) and
  icon_theme_cache_post(un), no longer needed for modern versions
  of openSUSE.
Version: 3.4.2-bp150.2.4
* Mon Oct 17 2016 zaitor@opensuse.org
- Update to version 3.4.2:
  + Application name not translated in about dialog.
  + Fixed make distcheck.
  + Updated translations.
* Wed Sep 23 2015 zaitor@opensuse.org
- Update to version 3.4.1:
  + Command line arguments not handled correctly.
  + Fix possible crash.
  + Updated translations.
* Wed Apr 15 2015 zaitor@opensuse.org
- Update to version 3.4.0:
  + Correctly update the play button icon after pausing.
  + Added symbolic app icon.
  + Updated translations.
* Fri Feb 27 2015 zaitor@opensuse.org
- Update to version 3.3.3:
  + Allow to start with no drive.
  + Update the window content after changing the drive in the
    preferences.
  + Fixed window auto resize.
  + Updated translations.
* Wed Mar 26 2014 zaitor@opensuse.org
- Update to version 3.3.2:
  + Updated obsolete info in license text (bgo#721455).
  + Properties: Set button arrow icons according to locale's text
    direction (bgo#722513).
  + notification: Set arrow icons according to locale's text
    direction (bgo#722176).
  + window: Set button arrow icons according to locale's text
    direction (bgo#722174).
  + Require gtk+ 3.10 or higher.
  + Updated translations.
* Wed Jan 15 2014 zaitor@opensuse.org
- Update to version 3.3.1:
  + Added support for writing MP3 files.
  + Preferences: use a single page to show all the preferences.
  + Show a message bar while fetching the disc information.
  + Set button arrow icons according to locale's text direction.
  + Added AppData description.
  + Updated translations.
- Drop goobox-3.8-and_above-compatible.patch, fixed upstream.
* Sun Sep 29 2013 zaitor@opensuse.org
- Add goobox-3.8-and_above-compatible.patch, in order to better fit
  with Gnome 3.8 and newer.
* Tue Apr 16 2013 dimstar@opensuse.org
- Update to version 3.2.1:
  + Correctly show an error dialog if some gstreamer plugin is
    missing.
  + Faster metadata download using read_sparse (bgo#697966).
  + Use the 'popup' attribute for the GtkMenuButton.
  + Updated translations.
* Thu Mar 28 2013 zaitor@opensuse.org
- Update to version 3.2.0:
  + Updated translations.
* Wed Mar 20 2013 zaitor@opensuse.org
- Update to version 3.1.2:
  + New features and user visible changes:
  - Use a cover size of 100x100.
  + Bugs fixed:
  - Fixed cover image fetching.
  - Check for ice and sm pkg-config in configure. (bgo#670941).
  + Internal code changes:
  - Ported to libmusicbrainz5.
  - Ported to GStreamer 1.0
  + Updated translations.
- Drop goobox-support-notification-filtering.patch and
  goobox-Port-to-libmusicbrainz5.patch, fixed upstream.
- Drop automake and libtool BuildRequires and stop passing autoconf
  to configure; no longer needed since we do not carry any patches
  anymore.
- Exchange pkgconfig(gstreamer-0.10) for pkgconfig(gstreamer-1.0)
  BuildRequires, following upstream port to gstreamer-1.0.
* Tue Feb 19 2013 zaitor@opensuse.org
- Add goobox-support-notification-filtering.patch, support
  notification filtering.
- Add goobox-Port-to-libmusicbrainz5.patch, port to libmusicbrainz5
- Add automake and libtool BuildRequires and run autoconf since the
  above patch touches the buildsystem.
- Stop passing obsolete --disable-scrollkeeper to configure.
* Tue Dec 18 2012 dimstar@opensuse.org
- Update to version 3.1.1:
  + New features and user visible changes:
  - Implemented a GNOME 3 like interface.
  - Added an application menu.
  - Fixed the window size with big playlists.
  + Bugs fixed:
  - Fixed skipping to a specific position.
  + Internal code changes:
  - Ported to libmusicbrainz 4.
  - Use libcoverart (if available) to get the CD cover.
  - Use GResource to store ui files.
  - Ported to the new documentation infrastructure.
  - Removed markup from translatable messages.
  - Removed use of deprecated functions.
  + Updated translations.
- Add pkgconfig(libcoverart) BuildRequires (currently disabled, as
  we do not yet have a package for it).
- Replace pkgconfig(libmusicbrainz3) BuildRequires with
  pkgconfig(libmusicbrainz4), following upstreams port.
- Replace gnome-doc-utils-devel BuildRequires with yelp-tools,
  following upstreams port to the new documentation infrastructure.
- Drop gconf2 BuildRequires: gconftool-2 is no longer needed.
- Remove conditions for no longer supported openSUSE versions (post
  scripts are now unconditionally configured).
* Sat Oct 13 2012 dimstar@opensuse.org
- Add gconf2 BuildRequires: used to be pulled in implicit by other
  packages. The build system makes use of gconftool-2, and thus
  requires this to be present.
* Fri Mar 30 2012 vuntz@opensuse.org
- Update to version 3.0.1:
  + Fixed compilation linking explicitly to the math library.
  + Updated translations.
* Tue Feb 28 2012 vuntz@opensuse.org
- Add pkgconfig(ice) and pkgconfig(sm) BuildRequires to fix build
  after the relayout of the xorg-x11 packages.
* Tue Oct 04 2011 dimstar@opensuse.org
- Update to version 3.0.0:
  + Removed use of deprecated code.
  + Updated translations.
* Thu Sep 01 2011 vuntz@opensuse.org
- Update to version 2.90.2:
  + Bugs fixed:
  - Fixed loading of the CD when /dev/cdrom doesn't exits.
  - Removed wrong use of the dark theme.
  + Internal code changes:
  - The documentation has been ported to Mallard.
  - Fixed compilation warnings.
  + Updated translations.
* Tue Jun 07 2011 vuntz@opensuse.org
- Update to version 2.90.1:
  + New features and user visible changes:
  - Ported to GTK+ 3.0, GSettings, GDBus, GtkApplication
  - Ported to libmusicbrainz 3
  - Added support for libnotify 0.7
  - Use symbolic icons
  - Preferer the dark theme
  - Added a high definition icon
  - Don't use the status icon with GNOME Shell
  + Bugs fixed:
  - Fixed CD cover search
  + Updated translations.
- Update pkgconfig() BuildRequires for this port to GNOME 3:
  + Drop dbus-glib-1, gconf-2.0, unique-1.0.
  + Change gtk+-2.0, libbrasero-media to gtk+-3.0,
    libbrasero-media3.
- Change libmusicbrainz-devel BuildRequires to
  pkgconfig(libmusibrainz3), and add pkgconfig(libdiscid)
  BuildRequires, for libmusicbrainz3 port.
- Replace GConf2 schemas handling with GSettings schemas handling,
  with %glib2_gsettings_schema_* macros, and remove gconf-specific
  - -disable-schemas-install configure flag.
* Thu Apr 28 2011 vuntz@opensuse.org
- Move to pkgconfig()-style BuildRequires:
  + Old ones: brasero-devel, dbus-1-glib-devel, gconf2-devel,
    gstreamer010-devel, libnotify-devel, libunique-devel.
  + New ones: dbus-glib-1, gconf-2.0, glib-2.0, gstreamer-0.10,
    gtk+-2.0, libbrasero-media, libnotify, unique-1.0.
* Sat Feb 12 2011 vuntz@opensuse.org
- Call relevant macros in %post/%postun:
  + %desktop_database_post/postun because the package ships at
    least one desktop file.
  + %icon_theme_cache_post/postun because the package ships themed
    icons.
- Pass %{?no_lang_C} to %find_lang so that english documentation
  can be packaged with the program, and not in the lang subpackage.
- Change Requires of lang subpackage to Recommends, since the
  english documentation is not there anymore.