Package Release Info

gnome-commander-1.8.1-bp152.3.20

Update Info: Base Release
Available in Package Hub : 15 SP2

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

gnome-commander
gnome-commander-doc
gnome-commander-lang

Change Logs

Version: 1.8.1-bp150.1.3
* Tue Mar 20 2018 dimstar@opensuse.org
- Unconditionally enable translation-update-upstream: on
  Tumbleweed, this results in a NOP and for Leap in SLE paid
  translations being used (boo#1086036).
* Mon Mar 05 2018 luc14n0@linuxmail.org
- Update to version 1.8.1:
  + New features:
  - Store the size of the options dialog when closing itself.
  - Remove unnecessary border lines from the options dialog tabs.
  + Bug fixes: Fix simple script system for file names with spaces.
  + Updated documentation.
  + Updated translations.
- Drop update-desktop-files BuildRequires and its macro: they are
  no longer required.
* Wed Feb 28 2018 dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
* Mon Oct 09 2017 luc14n0@linuxmail.org
- Update to version 1.8.0:
  + New features:
  - Quick search can be activated by just typing a letter,
    adjustable in the options tab.
  - Option for saving/not saving the:
    . Command line history on exit.
    . Search history on exit.
  - Added a settings option for deciding if the terminal window
    should stay open when a command finishes.
  - [build]:
    . Don't use gnome-autogen.sh anymore.
    . Translations are now handled by upstream gettext instead of
    intltool.
    . New documentation infrastructure: Use yelp-tools instead of
    gnome-doc-utils.
  + Other changes:
  - Increased minimum GTK version from 2.8.0 to 2.18.0.
  - Code cleanup.
  + Bug fixes: [build] Python is now found at build time, too, when
    its version is equal to or higher than 3.x.
  + Updated documentation.
  + Updated translations.
- Add itstool: new dependency.
- Add %fdupes macro: missing macro for the already had fdupes
  BuildRequires package.
- Add conditional use for translation-update-upstream: only non
  suse distributions need it.
- Drop %glib2_gsettings_schema_* and %desktop_database_* macros:
  functionality now covered by file triggers.
- Split package into a -doc subpackage: more than half the size of
  package is documentation.
- Replace gnome-doc-utils-devel BuildRequires by yelp-tools,
  following the port to the new documentation infrastructure by
  upstream.
- No longer pass --disable-scrollkeeper to configure: it is no
  longer recognized after the move to yelp-tools.
- GNOME Commander project has been moved to GitHub. The new home
  page now is located at http://gcmd.github.io/.
* Sat Sep 30 2017 zaitor@opensuse.org
- Pass --without-unique to configure, ensure that we do not depend
  on libunique.
* Sun May 28 2017 zaitor@opensuse.org
- Update to version 1.6.4:
  + Other favourite apps settings not saved (bgo#779574).
  + Internal-viewer by default display incorrect code pages
    (bgo#619112).
  + Updated translations.
* Mon Feb 27 2017 dimstar@opensuse.org
- Update to version 1.6.3:
  + Libunique (sometimes called only 'unique') is now optional via
    configure option.
  + Updated translations.
- Drop pkgconfig(unique-1.0) BuildRequires: following upstreams
  work to make this optional and recommendation to no longer use
  it.
* Sun Nov 06 2016 dimstar@opensuse.org
- Update to version 1.6.2:
  + New features:
  - Disk free space label is shown in status bar if device list
    isn't shown (works after restarting gcmd).
  - Shortcut can be assigned for:
    . Moving the cursor up or down.
    . Viewing bookmarks of current device ("Show bookmarks of
    current device").
  + Bugs fixed:
  - Color of marked files does not change when using theme colors
    (bgo#398734).
  - Device list entry width is set equal to the longest string in
    the list.
  - Fixed a bug in advance rename tool when utilizing METATAGS.
  + Updated translations.
* Sat Nov 05 2016 jengelh@inai.de
- Update descriptions.
- Remove redundant %clean section.
* Wed Nov 02 2016 dimstar@opensuse.org
- Update to version 1.6.1:
  + Selection background color not applied when using custom
    colors (bgo#638174).
  + Compiles with gcc6 -Werror=format-security (bgo#773063).
- Changes from version 1.6.0:
  + New features:
  - Always reopen the tab which was previously closed in the
    options dialog.
  - Samba support is now optionally available via configure
    option.
  - Configurable command for sending files to a preferred
    application.
  - Button 'Edit files' accepts more than one selected file at
    the same time.
  - Device buttons and device list entries act as 'home buttons'
    for that device when it is already active.
  - Copy directory path to clipboard after right click on
    dir-indicator.
  - Show/hide mainmenu can be set as keyboard shortcut now.
  - Simple plug-in system for file context menu.
  - Display of application icons in the "Open With" popup menu.
  - Write bookmark changes immediately to file, Sync bookmarks
    between all instances.
  - Storage of options is done in the dconf database now instead
    of a gnome-config file (bgo#570733).
  - Devices and fav-apps are now stored within the GKeyFile
    format.
  - File Roller plugin can use patterns of strftime when creating
    the archive name.
  - Started usage of google test framework for unit tests.
  - New colour theme 'Winter'.
  - Code cleanup.
  + Removed "Open folder" command in popup menu and user actions.
  + Bugs fixed: bgo#671616, bgo#683087, bgo#742752, bgo#767158,
    bgo#769309, bgo#770062, bgo#770063.
  + Updated translations.
- Align BuildRequires with configure:
  + Removed: libexiv2-devel, libgnomeui-devel, libgsf-devel,
    libxslt, taglib-devel
  + Added (pkgconfig()-style): exiv2, glib-2.0, gmodule-2.0,
    gobject-2.0, gtk+-2.0, libgnome-2.0, libgnomeui-2.0, libgsf-1,
    taglib.
- Add %glib2_gsettings_schema_post/postun to the respective
  scriptlets to handle the newly installed glib schemas.
- Drop obsolete conditions for openSUSE 11.3.
* Sun Sep 18 2016 zaitor@opensuse.org
- Update to version 1.4.9:
  + bgo#764306: Spelling mistake and wrong words in strings.
  + Updated translations.
* Tue Mar 15 2016 dimstar@opensuse.org
- Update to version 1.4.8:
  + bgo#761580: Support gcc6 -Werror=format-security.
  + Updated translations.
* Sun May 31 2015 dimstar@opensuse.org
- Update to version 1.4.7:
  + bgo#745454: Segmentation fault after find files.
  + bgo#749869: Segfault on the second search.
  + bgo#734032: Clicking on .png file looks at wrong MIME type.
  + Updated translations.
* Wed May 20 2015 dimstar@opensuse.org
- Update to version 1.4.6:
  + Bugs fixed: bgo#653573, bgo#742752, bgo#746003, bgo#747771,
    bgo#748869.
  + Updated translations.
- Drop gnome-commander-appdata-translation.patch: fixed upstream.
- Remove libtool BuildRequires and call to autoreconf, as we no
  longer carry any patches.
* Mon Apr 13 2015 dimstar@opensuse.org
- Add gnome-commander-appdata-translation.patch: Do not handle
  appdata.xml.in as a config file, but let INTLTOOL_XML_RULE handle
  it.
- Add libtool BuildRequires and call to autoreconf, as above patch
  touches the build system.
* Sun Jan 25 2015 zaitor@opensuse.org
- Update to version 1.4.5:
  + Fixed appdata missing in POT (bgo#741316).
  + Fixed Option --start-right-dir crashes gnome-commander
    (bgo#742716).
  + Removed python-2.6 support from gentoo ebuild.
  + Updated translations.
* Fri Nov 14 2014 zaitor@opensuse.org
- Update to version 1.4.4:
  + Migrated from gnome_execute_shell to g_spawn_async
    (bgo#571495).
  + Support for user's terminal different from gnome-terminal
    (bgo#737088).
  + Updated translations.
* Fri Jul 11 2014 dimstar@opensuse.org
- Update to version 1.4.3:
  + Fix crash when drag 'n drop objects via mouse (bgo#731557).
- Changes from version 1.4.2:
  + Switched from python-r1 to python-single-r1 in ebuild
  + bgo#367949: Corrected async_xfer_callback-results for moving
    folders.
  + bgo#598161: Selecting text in internal viewer on lines with
    TANew features.
  + Text selection in int. viewer works on lines with TAB
    characters.
  + Updated translations.
* Sat Apr 05 2014 zaitor@opensuse.org
- Update to version 1.4.1:
  + Fix bgo#641842: use poppler-glib instead of poppler internal
    API.
  + Fix bgo#726682: Fix for undefined reference to vtable.
  + Support for utf8 encoded creation and modification dates in
    document metadata.
  + Moved Search, Quick Search and Enable Filter from Edit to File
    menu.
  + Updated translations.
- Replace libpoppler-devel for pkgconfig(poppler-glib)
  BuildRequires following upstream changes.
- Drop gnome-commander-docs.patch: Fixed upstream.
* Mon Mar 17 2014 dimstar@opensuse.org
- Update to version 1.4.0:
  + Support for tabs.
  + Revamped bookmarks dialog.
  + Revamped file properties dialog.
  + One instance mode.
  + New colour theme: green tiger.
  + User defined LS_COLORS colours.
  + Possibility to select/deselect files only.
  + Support for automatic width counters in advanced file rename.
  + Enhanced file name matching in quick search.
  + Open terminal with administrator privileges.
  + Prompt to confirm drag & drop operations.
  + Right click popup menu for copying in internal viewer.
  + --config-dir command line option for customized location of
    config files.
  + Several speed improvements including C++ rework and code
    cleanups.
  + New python plugin: 'apply_patch'.
  + Dropped broken MIME type configuration.
  + Dropped support for cvs plugin.
  + Adjusted keybindings.
  + Updated documentation.
  + Bugs fixed: bgo#377463, bgo#492479, bgo#617140, bgo#632064,
    bgo#632208, bgo#633107, bgo#633167, bgo#633331, bgo#634972,
    bgo#637873, bgo#638059, bgo#660043, bgo#660268, bgo#667080,
    bgo#696227, bgo#684527, bgo#660063, bgo#642178, lp#117226.
  + Updated translations.
- Add pkgconfig(gnome-keyring-1) and pkgconfig(unique-1.0)
  BuildRequires: new dependencies.
- Add gnome-commander-docs.patch: Fix installation of documentation
  figures.