Package Release Info

gnome-code-assistance-3.16.1-bp153.1.17

Update Info: Base Release
Available in Package Hub : 15 SP3

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

gnome-code-assistance

Change Logs

Version: 3.16.1-bp151.1.1
* Fri Oct 19 2018 msrb@suse.com
- Resubmit to SP1 to rebuild with updated llvm. (fate#325696)
* Fri Dec 15 2017 dimstar@opensuse.org
- Fix some rpmlint warnings:
  + env-script-interpreter: Replace (using sed) /usr/bin/env FOO
    hasbangs.
  + empty-%post/postun: disable the scripts on suse_version > 1320:
    %glib2_gsettings_schema_post/post are no longer needed as the
    %functionality is covered by file triggers.
* Mon Dec 04 2017 dimstar@opensuse.org
- Add Add-vala-0.40-support.patch: Fix build with vala 0.40, taken
  from git.
* Tue Aug 08 2017 jengelh@inai.de
- Fix RPM group. Trim future visions from descriptions.
* Thu Jul 20 2017 zaitor@opensuse.org
- Add 0005-Add-vala-0.38-support.patch: Fix build with vala 0.38,
  patch taken from git.
* Fri Mar 03 2017 dimstar@opensuse.org
- Add 0001-Add-libvala-0.36-support.patch and
  0003-Fix-compilation-with-vala-0.36.patch: Fix build with
  vala 0.36, patches taken from git.
- Add libtool Buildrequires and call to autoreconf, as above patch
  touches the build system.
- Replace pkgconfig(libvala-0.34) BuildRequires with libvala-devel:
  we do not want to change the version every 6 months any longer.
* Fri Sep 16 2016 dimstar@opensuse.org
- Build using vala 0.34:
  + Replace pkgconfig(libvala-0.32) BuildRequires with
    pkgconfig(libvala-0.34).
* Tue Jul 05 2016 zaitor@opensuse.org
- Update to version 3.16.1:
  + Fix compatibility with sass 3.4.22.
  + Support vala 0.34.
  + Fix crash when pylint is not available.
  + Update javascript dependencies.
- Stop passing sed, libvala-0.32 is now supported by upstream.
- Drop gca-python-fix-crash-when-missing-pylint.patch: Fixed
  upstream.
* Wed Mar 30 2016 zaitor@opensuse.org
- Prepare for libvala-0.32 via sed replacement.
- Following above change, replace pkgconfig(libvala-0.30) for
  pkgconfig(libvala-0.32) BuildRequires.
- Add gca-python-fix-crash-when-missing-pylint.patch: Fix crash
  when pylint is not available. Patch from upstream git.
* Wed Aug 19 2015 zaitor@opensuse.org
- Prepare for libvala-0.30 via sed replacement.
- Following above change, replace pkgconfig(libvala-0.28) for
  pkgconfig(libvala-0.30) BuildRequires.
* Thu Apr 30 2015 dimstar@opensuse.org
- Update to version 3.16.0:
  + Update sass.
  + Add jshint support.
- Drop gnome-code-assistance-vala-0.28.patch: Fixed upstream.
* Thu Feb 05 2015 dimstar@opensuse.org
- Add gnome-code-assistance-vala-0.28.patch: Add support for
  Vala 0.28 branch.
- Add libtool BuildRequires and call to autoreconf, as above patch
  touches the build system.
- Replace pkgconfig(libvala-0.26) BuildRequires with
  pkgconfig(libvala-0.28).
* Mon Feb 02 2015 zaitor@opensuse.org
- Disable c-backend (llvm) for PPC: llvm-devel BuildRequires is not
  available on PPC. Doing this via conditional %ifnarch.
* Thu Dec 04 2014 zaitor@opensuse.org
- Update to version 3.14.0:
  + Improvements in the C and Vala backends.
  + gnome-code-assistance now uses the same versions as GNOME's.
- Stop adding libvala-0.26 via sed in spec, no longer needed, fixed
  upstream.
* Mon Sep 29 2014 dimstar@opensuse.org
- Use vala 0.26 with GNOME 3.14:
  + Replace pkgconfig(libvala-0.24) BuildRequires with
    pkgconfig(libvala-0.26).
  + Use sed to add libvala-0.26 as supported vala version to
    configure.
* Tue Sep 09 2014 mrueckert@suse.de
- Fix buildrequires for the ruby support:
  - ruby(abi) is no longer numerical. Use versioned ruby
    BuildRequires.
  - Use rubygem(ruby-dbus) instead of rubygem-ruby-dbus.
* Wed Mar 26 2014 zaitor@opensuse.org
- Update to version 0.3.1:
  + Improvements in backends.
  + Added unit tests.
  + Lots of bugfixes.
* Fri Feb 14 2014 zaitor@opensuse.org
- Enable the vala backend as we have the required vala version now,
  and therefore "activate" pkgconfig(gobject-2.0),
  pkgconfig(glib-2.0), pkgconfig(gio-2.0), pkgconfig(gee-0.8),
  pkgconfig(libvala-0.24) and add pkgconfig(vapigen)
  BuildRequires and pass --enable-vala to configure.
* Fri Feb 14 2014 zaitor@opensuse.org
- Exchange ruby20 for ruby(abi) BuildRequires, will save us trouble
  on future updates of ruby.
* Tue Dec 17 2013 dimstar@opensuse.org
- Initial package, version 0.3.0.
Version: 3.16.1-bp152.4.12
* Mon Jan 06 2020 Michael Gorse <mgorse@suse.com>
- Add vala-0.46.patch: build against vala 0.46 (boo#1158384).