Package Release Info

flamerobin-0.9.3.1-bp154.1.63

Update Info: Base Release
Available in Package Hub : 15 SP4 (BETA)

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

flamerobin

Change Logs

Version: 0.9.3.1-bp150.2.3
* Wed Feb 01 2017 adam.majer@suse.de
- use individual libboost-*-devel packages instead of boost-devel
* Thu Sep 29 2016 badshah400@gmail.com
- Update to version 0.9.3.1:
  + New templating system allows you to add you own SQL statement
    templates to the menu
  + BLOB editor
  + Extended dialog with SQL statement history makes it easier to
    search
  + View dependencies are resolved properly for Firebird 2.5
  + Fixed statistics for UPDATE OR INSERT statements
  + DataGrid: implemented Copy as IN list
  + DataGrid: Fixed keyboard navigation
  + Added new context menu options
  + Fixed error messages when different character set is used in
    statements
  + Warn when closing SQL editor with active transactions
  + Ability to refresh list of objects in the main tree
  + Fixed bug with quoted identifier when altering column type
  + Generate change script is now available for columns as well
  + Fixed truncating of Unicode characters with Firebird 1.5
- Update required version of wxwidgets to >= 3.0.
- Drop flamerobin-0.9.2-wxWindowListNode.patch; fixed upstream.
- Use github tagged tarball for source; update %setup accordingly.
- Add flamerobin-desktop-file.patch to remove hardcoded reference
  to location of icon file.
- Extract hicolor icons of all possible sizes from bundled icns
  file and install them to hicolor icon dir; adds BuildRequires
  on icns-utils, hicolor-icon-theme; run
  %icon_theme_cache_post(un) post(un) scriptlets.
- Sed to fix a trailing ';' issue in .desktop file.
* Fri Jul 03 2015 mpluskal@suse.com
- Cleanup spec file with spec-clener
- Update desktop file scriplet dependencies
* Tue May 22 2012 mkubecek@suse.cz
- adjust BuildRequires for Firebird 2.5 packages
* Thu Dec 15 2011 cfarrell@suse.com
- license update: MIT and LGPL-2.1+
  See the Readme - mostly MIT (including the IBPP) but some icons are
  LGPL-2.1+
* Thu Dec 08 2011 coolo@suse.com
- "BSD" is not a valid spdx.org license
* Tue Oct 04 2011 mhrusecky@suse.cz
- Adding '-fpermissive' to fix build on Factory
* Wed Dec 29 2010 sbrabec@suse.cz
- Compile with wxWidgets (STL variant).
* Fri Jul 03 2009 mhrusecky@suse.cz
- Fixed build with wxUSE_STL enabled
* Tue Jun 30 2009 makowski@firebird-fr.eu.org
- First OpenSuse build
* Sun Apr 12 2009 makowski@firebird-fr.eu.org
- First Fedora build
- New upstream: 0.9.2
* Tue Mar 24 2009 makowski@firebird-fr.eu.org
- Update to 0.9.0
- First mipsel build
* Thu Jul 24 2008 tvignaud@mandriva.com
+ Revision: 245195
- rebuild
* Thu Jan 31 2008 mrl@mandriva.com
+ Revision: 160873
- New upstream: 0.8.3
  + Olivier Blin <oblin@mandriva.com>
  - restore BuildRoot
  + Thierry Vignaud <tvignaud@mandriva.com>
  - kill re-definition of %%buildroot on Pixel's request
* Thu Oct 18 2007 mrl@mandriva.com
+ Revision: 99959
- Fix configure permission.
- New upstream: 0.8.1
- New upstream: 0.8.0
* Tue May 15 2007 mrl@mandriva.com
+ Revision: 26964
- Rebuilt against new wx stuff.
* Wed Dec 20 2006 waschk@mandriva.org
+ Revision: 100700
- rebuild
* Mon Nov 27 2006 mrl@mandriva.com
+ Revision: 87367
- New upstream: 0.7.6
- Added menu icon.
* Thu Nov 16 2006 mrl@mandriva.com
+ Revision: 84903
- Added BuildRequires for ImageMagick: due to convert usage.
- Rebuilt against firebird 2.0 final.
* Thu Sep 07 2006 mrl@mandriva.com
+ Revision: 60258
- New upstream: 0.7.5