Package Release Info

eb-4.4.3-bp151.3.1

Update Info: Base Release
Available in Package Hub : 15 SP1

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

eb
eb-devel
eb-lang
libeb16

Change Logs

Version: 4.4.3-bp150.1.3
* Fri Jul 01 2016 toddrme2178@gmail.com
- Fix Group tag.
* Sat Dec 26 2015 i@marguerite.su
- eb-devel should requires eb, which requires libeb16.
  or applications like ebview won't build because lack
  of /etc/eb.conf
* Tue Jan 06 2015 p.drouand@gmail.com
- Update to version 4.4.3
  + eb/ebnet.c (ebnet_open): Use _atoi64() or atol(), when atoll()
  is not available.
  + configure.ac (LIBEB_VERSION_INFO):
  EB Library verison 4.2.2 sets LIBEB_VERSION_INFO to 15:0:2,
  but it is wrong.  To avoid the confusion, I decide to update
  LIBEB_VERSION_INFO to 16:0:0.
- Split out translation files in a lang subpackage and recommend it
  by the main package
- Split out the system library in libeb16 subpackage; follow shared
  library packaging guidelines
- Do not provide the INSTALL file; we're not concerned
- Update the Url
- Use download Url as source
- Make devel subpackage depends on libeb16 instead of eb
- Remove redudant "eb" in Summary; fix related rpmlint warning
- Remove bugzilla-242268.patch; merged on upstream release
* Fri Sep 30 2011 coolo@suse.com
- add libtool as buildrequire to make the spec file more reliable
* Sun Sep 18 2011 jengelh@medozas.de
- Remove redundant/obsolete tags/sections from specfile
  (cf. packaging guidelines)
- Use %_smp_mflags for parallel build
- Undebianify ebdev to eb-devel
* Mon Feb 25 2008 crrodriguez@suse.de
- fix library-without-ldconfig-postin errors
- spec file cleanup
- remove libtool archives and static libraries
- use find_lang macro where needed
* Fri Mar 30 2007 ro@suse.de
- added zlib-devel to buildreq
* Tue Feb 06 2007 mfabian@suse.de
- bugzilla #242268: array subscript is above array bounds.
* Tue Feb 06 2007 mfabian@suse.de
- update to 4.3.
  ? fix a problem with shared directories with EPWING dictionaries
  ? fix the problem that ?ebunzip --test? did overwrite the
    main dictionary file.
  ? fix the problem that ebappendix created an appendix in
    electronic book form even when reading a catalogs.app file.
  ? make colour illustrations with reference links work.
  ? API Additions:
    new functions: eb_have_image_menu(), eb_image_menu().
    new text hooks: EB_HOOK_BEGIN_IMAGE_PAGE,
    EB_HOOK_END_IMAGE_PAGE, EB_HOOK_BEGIN_CLICKABLE_AREA,
    EB_HOOK_END_CLICKABLE_AREA
* Wed Feb 08 2006 ro@suse.de
- workaround glibc(?) problem with localedir being .locale
  in configure
* Wed Jan 25 2006 mls@suse.de
- converted neededforbuild to BuildRequires
* Wed Jun 08 2005 tiwai@suse.de
- updated to version 4.2.
* Wed Apr 13 2005 mfabian@suse.de
- use gt_LC_MESSAGES instead of AM_LC_MESSAGES in gettext.m4
  to make it build.
* Tue Dec 07 2004 pth@suse.de
- Fix quoting in AC_DEFUN
* Sat Jan 10 2004 adrian@suse.de
- build as user
* Sat Aug 23 2003 mfabian@suse.de
- update to eb-3.3.4.
- use %run_ldconfig.
* Thu Apr 24 2003 ro@suse.de
- fix install_info --delete call and move from preun to postun
* Thu Feb 13 2003 mfabian@suse.de
- I forgot "Prereq:       %install_info_prereq", sorry.
* Wed Feb 12 2003 mfabian@suse.de
- update to eb-3.3
- use %install_info macro (Bug #23401)
* Tue Aug 13 2002 mfabian@suse.de
- update to eb-3.2.2
  according to the NEWS file:
  * Fix bug in handling of appendix.
  * Fix gettext message catalogs.
  and now the Oxford Concise dictionary works perfectly in UTF-8
  for me with eb-3.2.1 I still had problems using the Oxford
  Concise in UTF-8.