Package Release Info

dleyna-renderer-0.6.0-bp153.1.16

Update Info: Base Release
Available in Package Hub : 15 SP3

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

dleyna-renderer
dleyna-renderer-devel

Change Logs

Version: 0.6.0-bp150.1.3
* Fri Feb 16 2018 bjorn.lie@gmail.com
- Update to version 0.6.0:
  + Ensure that g_context.watchers has a valid value.
  + Used core functionality dleyna_core_prv_convert_udn_to_path for
    persistent path.
  + [m4]:
  - Don't use bash arrays in m4 macros.
  - Don't use bash "let" builtin.
  - Use AS_VAR_APPEND macro instead of "+=".
  + Avoid any attempts to delete the same dlr_upnp_t twice.
  + Uninitialized argument value in prv_open_uri_cb.
- Do a minor spec cleanup, add missing COPYING.
- Add libtool BuildRequires and pass autoreconf, bootstrap tarball.
- Pass --disable-static to configure, ensure we do not build any
  static files.
* Sat May 02 2015 zaitor@opensuse.org
- Update to version 0.5.0:
  + [Deprecated API] Use new API instead of deprecated.
  + [Device]:
  - Free dlna class strings after use.
  - Update playspeed when rate is set.
  + [host-service] use push-host-port setting for the web server.
  + [upnp] use port setting when creating GUPnPContextManager.
  + [Autoconf]:
  - Add Math lib to link.
  - Sub Makefile: Remove ACLOCAL_AMFLAGS.
  + [daemon] use GLib signal handling.
  + [Configuration] Remove libdleyna-renderer .pc file.
* Mon Aug 25 2014 dimstar@opensuse.org
- Update to version 0.4.0:
  + Added support for Network filtering.
  + Settings can now be modified via d-Bus.
  + The OpenURI method now adheres to the MPRIS2 standard.
  + Use MIME Type from GUPnP-DLNA if available.
* Sat Sep 14 2013 dimstar@opensuse.org
- Update to version 0.1.3:
  + GetRenderers() should return an array of object paths "ao"
    instead of an array of strings "as".
  + dLeyna renderer can crash if renderer dissapears (7.2.8.4,6).
  + Fixed a build issue: [Build] Ship the internal library in a
    private directory.
- Drop libdleyna-rendere subpackage: this was not meant to be
  provided as a system lirary by upstream, but rather a private
  library. Thus, the lib has been moved to a private space
  (%{libdir}/%{name}/).
- As a consequence, no longer require libdleyna-renderer-1_0-1 from
  the -devel package.
- Require the main package from the -devel package (the private
  library still has a .so file which could result in a dangling
  symlink otherwise).
* Mon Aug 12 2013 dimstar@opensuse.org
- Initial package, version 0.1.1.
Version: 0.6.0-bp152.4.14
* Sat Oct 12 2019 Bjørn Lie <bjorn.lie@gmail.com>
- Add dleyna-renderer-port-gupnp.patch: Port to use new gupnp-1.2.
  Replace pkgconfig(gssdp-1.0) and pkgconfig(gupnp-1.0) with
  pkgconfig(gssdp-1.2) and pkgconfig(gupnp-1.2) BuildRequires.