Package Release Info

ffmpeg-4-4.0.1-7.1

Update Info: openSUSE-2019-560
Available in Package Hub : 12 SP2-SP5

platforms

AArch64
ppc64le
s390x
x86-64

subpackages

ffmpeg-4-libavcodec-devel
ffmpeg-4-libavdevice-devel
ffmpeg-4-libavfilter-devel
ffmpeg-4-libavformat-devel
ffmpeg-4-libavresample-devel
ffmpeg-4-libavutil-devel
ffmpeg-4-libpostproc-devel
ffmpeg-4-libswresample-devel
ffmpeg-4-libswscale-devel
ffmpeg-4-private-devel
libavcodec58
libavdevice58
libavfilter7
libavformat58
libavresample4
libavutil56
libpostproc55
libswresample3
libswscale5

Change Logs

* Fri Jul 27 2018 tchvatal@suse.com
- Reduce the optional conditional for the SLE12 backports to
  cover everything, most of the packages in old codestreams were
  not really ready as they need additional baselibs/etc.
  * Since these are new features user will simply wait or use TW
* Fri Jul 27 2018 jengelh@inai.de
- Enable "kmsgrab" input device
* Thu Jul 26 2018 tchvatal@suse.com
- Redo the nvidia condition based on review feeback
* Wed Jul 25 2018 tchvatal@suse.com
- Do not condition nvidia based on BUILD_ORIG all the support is in
  TW only and not on different instances as such safeguard it with
  version check only bsc#1102532
Version: 4.0.1-10.1
* Tue Jul 31 2018 tchvatal@suse.com
- bsc#1103064 attempt to allow migration from the unprefixed devel
  packages cleanly
Version: 4.0.1-2.2
* Wed Jul 18 2018 tchvatal@suse.com
- Add new bconds to build on SLE12 backports project without
  requiring extra packages:
  * %bcond_without codec2
  * %bcond_without bs2b
  * %bcond_without lv2
  * %bcond_without rubberband
  * %bcond_without soxr
  * %bcond_without zmq
* Fri Jul 06 2018 tchvatal@suse.com
- Fix typo in swresample name
* Wed Jul 04 2018 tchvatal@suse.com
- Conditionalize full build to be primary only on Leap15+
* Tue Jul 03 2018 tchvatal@suse.com
- Add macros to allow conflicting with all other devel projects
  to ensure we always install only one specific ffmpeg
* Sat Jun 30 2018 tchvatal@suse.com
- Conditionalize the vidstab build to not pull it on old releases
- Conditionalize srt support to not pull it on older releases
  - ------------------------------------------------------------------
* Fri Jun 29 2018 9+suse@cirno.systems
- Enable ffnvcodec when building with NVIDIA support
* Fri Jun 29 2018 bjorn.lie@gmail.com
- Add pkgconfig(srt) BuildRequires and pass --enable-libsrt to
  configure, enable srt support.
- Refresh patches with quilt:
  * cve-2017-17555.diff
  * ffmpeg-codec-choice.diff
  * ffmpeg-libcdio_cdda-pkgconfig.patch
  * ffmpeg-new-coder-errors.diff
* Fri Jun 29 2018 9+suse@cirno.systems
- Enable libxml2 (used by MPEG DASH demuxer)
* Wed Jun 27 2018 jengelh@inai.de
- Update to new upstream release 4.0.1
  * Fixed some integer overflows, undefined shifts, negative
    shifts, division by 0, and a null pointer deref.
* Mon Jun 18 2018 bjorn.lie@gmail.com
- Enable pkgconfig(vidstab) BuildRequires unconditionally, now
  available in openSUSE.
* Thu Jun 14 2018 tchvatal@suse.com
- Conditionalize openmpt build to be resolvable on Leap 42.3
* Thu Jun 14 2018 tchvatal@suse.com
- Conditionalize mysofa build to be resolvable on Leap 15
* Thu Jun 14 2018 tchvatal@suse.com
- Conditionalize zimg to build on Leap 42.3
* Thu Jun 14 2018 tchvatal@suse.com
- Use autopatch
* Wed Jun 13 2018 tchvatal@suse.com
- Provide ffmpeg symbol without version on main package too
* Wed Jun 13 2018 tchvatal@suse.com
- Prefix all the devel packages and conflict between releases
  * Provide always the %version-%release of the respective build
* Wed Jun 13 2018 tchvatal@suse.com
- Fix setup call to enter to proper folder
* Wed Jun 13 2018 tchvatal@suse.com
- Conflict with other ffmpeg-devel packages, simply always pull
  one of them
* Wed Jun 13 2018 tchvatal@suse.com
- Move license markings to the libs itself
- Add condition to switch between full build and lib only one
- Add provides/obsoletes on the ffmpeg private headers
* Sat Jun 02 2018 9+suse@cirno.systems
- Reintroduce conditional libxvid support since FFmpeg?s
  MPEG4-ASP encoder is not quite up to par